Results 1 to 8 of 8
  1. #1
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365

    sl900 bogging issues

    Ok I took it out yesterday for the first time this season and it starts great. It will bogg if you slam the throttle from a stop position. but 1/4 to 3/4 throttle (up to 6100 rpms) is pretty smooth and runs alright. If you push it to get that last 1/4 throttle it boggs and sputters. It did this at the end of last season but I never had a chance to look at it.

    Over the winter I

    rebuilt carbs
    new fuel lines
    converted to premix

    I set the carbs lows to factory specs
    the pop off was mag-20 center-20 pto-19-20ish

    I did pull the choke during take off and it just wanted to kill the engine so i dont think it is running lean at any time. any suggestions? I know pop off is at the low end.


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    When you replaced the fuel lines,did you save and reinstall the Fuel line restrictor? Here's the post on how to make one if you tossed it. Post #13

    http://www.greenhulk.net/forums/show...t=12649&page=2

    Opps, that a 900 with keinth carbs,never mind that thought.

    What was it doing before you did all the work?

  3. #3
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    it acted the same way at the end of last season before i did any work to it. It ran good at the start of the season last year running with my 1100zxi.

  4. #4
    Check to see if the accelerator pump is working.

    Pull the air cleaner/flame arrestor. Run it for a few seconds and then kill the engine. Look down the carbs and pull the throttle. You should see a burst of fuel coming of of the little brass jets at the top of the carbs. You can usually get 2-3 squirts out of them with the engine off.

    On one of my 1050 carb racks, the accelerator jets were completely clogged. I pulled the carbs off and hit the jets with compressed air and it cleaned them right out.

  5. #5
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    the accelerator pump was working when i put the carbs back on and got the new premix up in. I will double check it though.

  6. #6
    My SLTX was doing something very similar. The advice on here at the time was to open the adjusters 1/4 turn at a time until the bogging goes away....obviously don't just keep opening them if it doesn't seem like that's helping.

  7. #7
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    Since the lows are the only thing you can adjust would this help the full throttle issue? I know it would help take off.

  8. #8
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    well i checked the accelerator pump jets and the mag jet was clogged. I got it working good now. I am sure it will help. I will probably try and turn the lows out a bit more and see what that does.

    Would this affect my top end throttle response?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 sl900 electrical issues?
    By astfu in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-06-2010, 02:47 PM
  2. 95 hx bog issue
    By sschne62 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-03-2010, 01:25 AM
  3. 1200R Engine/Bog Issue, PLEASE HELP
    By GP1300Racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-14-2009, 08:07 PM
  4. 2002 gp 1200 bog issue
    By jhand in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-30-2008, 11:06 AM
  5. SL900 Electrical Issues
    By Drew13 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 12-23-2007, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •