Results 1 to 3 of 3
  1. #1
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,587
    +1
    2

    what do you need to do to run Seadoo pump w/ VTS on conversion

    So,

    this issue is that when installing the seadoo pump the VTS rod don't line up with the hole that is on the yamaha.

    what are you guys doing to use the VTS rod with the Seadoo pump

    Do you plug this hole, then drill a new one? How do you plug the hole?

    pics?


  2. #2
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by HallPass View Post
    So,

    this issue is that when installing the seadoo pump the VTS rod don't line up with the hole that is on the yamaha.

    what are you guys doing to use the VTS rod with the Seadoo pump

    Do you plug this hole, then drill a new one? How do you plug the hole?

    pics?
    im kinda interrested in this too .... im asuming you would glass or marine tex etc the hole up and drill a new one ..

    if your using jasons pump adaptor, doesnt that block half the hole where the factory yam trim comes through .. it does on mine anyway

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    I'm just using a manual mechanical drop with my trim nozzle. Sorry.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What do i need to run turbo??
    By daredevil828 in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-24-2008, 06:31 PM
  2. What else is needed to run Riva ECU?
    By Gus13letter in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-21-2008, 02:56 PM
  3. What do you need to go from stg3 to turbo?
    By ski-guy1 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-11-2008, 07:39 PM
  4. what do you need to do to install a cam
    By breon in forum 4-Tec Performance
    Replies: 23
    Last Post: 12-25-2007, 02:02 PM
  5. Do you need to prime oil pump if ur warning beep goes off?
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-02-2007, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •