Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Help With Polaris Sl750

    Hey Guys, Last year i bought a Polaris Sl750 1993. but the first time i took it out, it made a hole in the first piston from the front, i disassembled the engine and cleaned it and replaced piston and rings and new gaskets.

    Now the machine is assembled again, i took it out for a spin, it ran fine but found fast out that the thermostat assembly was clocked. and no water was delivered, i turned of the engine immediately , i cleaned the thermostat but now i have an issue the engine will not run properly, at high speeds its start fine. but will not accelerate, to more than cruising speed. but when i turn the Fuel shut of valve to off some seconds while running and then back on the engine will accelerate for some seconds,

    That was i my opinion some thing wrong with fuel shut off valve or lines,.
    i checked that and it was fine, i cheeked the fuel line and it seams to be fine also, i have a transparent fuel filter and i can see that there is not enough fuel delivered to the pump. while the engine is running..
    i have routed the fuel line along the side off the craft in the black clips,.

    i also have a little problem with the water routing, because when i look in the manuals for the 1993 Model my engine does not have any water hoses connectors on the crankcase. like in the manual but it have an connector on the exhaustmanifold and in the manual this thing dosent exist, and on the exhaust pipe there is to connectors one on the side, one on the top and one big at the bottom where the draining hose is.? it looks verry wrong. but it is the way that it is assembly from the last owner,

    It is of curse possible for me to take some pictures if anyone want to see what i mean ?

    Please help me guys, and sorry for my crappy english.


  2. #2
    Canadian Beaver Inspector jkindt's Avatar
    Join Date
    Sep 2009
    Location
    Lethbridge, AB, Canada
    Posts
    1,721
    STOP! Don't run the ski again until you get some important issues sorted out. The fuel systems on these skis need to be upgraded or you will continue to burn holes in that piston. Click on the link below in my signature and read about the FUJI engine. That is what you have in that ski.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk.

    There are many fuel related issues that have been asked about similar skis. Please read up on them and inspect/upgrade the fuel system.

    Picks of the engine and cooling system would be helpful.

  4. #4

    Fuel pump

    I have installed the double fuel pump and Lines betwen the caburators and blinded the original Line in,

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Quote Originally Posted by Puerto-Rico View Post
    I have installed the double fuel pump and Lines between the carburetors and blinded the original Line in,
    Double fuel pump?

    What exactly have you installed in there?

  6. #6

    explanation,

    First when it got the ski i read about the fuel problem, but the last owner had repleced the pump to a mikuni pump with 2 outputs lines but he had connecyed it like a one line supply and closed the second output i installed like i read on the web, 2 fuel lines from the pump, and closed the orginal inlet and connected a line betwen the carbs, i can take som pic if you dont understand me

  7. #7
    Canadian Beaver Inspector jkindt's Avatar
    Join Date
    Sep 2009
    Location
    Lethbridge, AB, Canada
    Posts
    1,721
    I am sure most of us have seen what you are talking about. Usually the 'dealer' just tee'd the single outlet into two, then attached them as you stated. It is still insufficient and will lean out at WOT. You need a TRIPLE outlet fuel pump (or three singles), and run one line to each carb. The return lines may be left as stock.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    We need pics....

  9. #9

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127
    delete my post please wrong place

  10. #10

    Pump...

    i have checked the machine and found out that i have a mikuni DF62-702 instaled. this model is oversized for this jetski and should not have any problems to deliver fuel it a 2 output pump 65l /H?''' how can i check if this pump is broken without a gauge?

    http://www.mikuni.com/fs-carburetor.html

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. In Need of Fast Help with Polaris Genesis Reverse Unit Wire
    By peteyb in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-12-2010, 12:28 AM
  2. Need help with Polaris Genesis
    By Studio143 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 08-09-2010, 07:24 PM
  3. I need help with Polaris 1200 head
    By fatboyztoyz in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-22-2009, 06:44 PM
  4. New to the Hulk need a little help with Polaris Virage
    By Tailfisher in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-13-2009, 01:23 PM
  5. need help with polaris slh 700
    By holcomb21 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 06-08-2008, 03:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •