Results 1 to 6 of 6
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    Videos of the impeller noise from previous post

    wont let me post it in original post...

    Here are the videos

    Ideas? should i try the other impeller?

    <-- without sparkplugs


    <-- with sparkplugs in


  2. #2
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Apparently that post went through o well... new thread

  3. #3
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    does it start and run ?

  4. #4
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    Who can say for sure without a personal inspection, but it sounds like any other Polaris I've ever heard before. Going by ear, it sounds completely normal. But, doublecheck everything if you feel you may have missed something.

  5. #5
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    He should start it up and let us hear it running in the water , all polaris's rattle a little out of the water. you cant hear that stuff while its running in the water. ill have to try that on the slx, plugs in plugs out and see if I can hear any difference from my 1200.

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by CrazyA View Post
    Who can say for sure without a personal inspection, but it sounds like any other Polaris I've ever heard before. Going by ear, it sounds completely normal. But, doublecheck everything if you feel you may have missed something.
    Agreed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video: JetPilotís Battle of The Best Showdown From RNR7
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 10-10-2014, 12:20 AM
  2. Free Ride Video Of the Weekend
    By Mik72e in forum Australia
    Replies: 8
    Last Post: 01-26-2014, 11:11 PM
  3. Got the impeller back from Impros
    By 97GPSLEEPER in forum Yamaha Old School Skis
    Replies: 34
    Last Post: 10-12-2009, 04:13 PM
  4. Anyone See The Video of the 98XPL of Rappid racing?
    By Angelse68cal in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 12-01-2008, 08:13 PM
  5. Anyone have the video of the Snowmobile vs. Jetski
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-01-2006, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •