Results 1 to 3 of 3
  1. #1

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2

    Fuel system De-priming?

    Not sure if de-priming is a word.

    After the ski sits for about a week or so, maybe a little less, I go to start it and the fuel system needs to be primed again. There is about 2 inches of emptyness in the water/fuel separator and all that has to be primed before it gets to the carbs. Other than that the ski runs great. If it sits for a couple of hours in the water its fine, only when its sitting on trailer for a few days. It didn't do this with the stock pump.

    Thanks.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    What model and year?

    Are you turning the fuel selector valve off when you are done riding?

    You may have an air leak in the fuel system. Make sure every component in the fuel system is sealling really well.

    Pay attention to the fuel selector valve (internal O-ring seal), and the sealing at the fuel/water separator.

    The fuel pump check valves may be bleeding down (not sealing 100%) and allowing air to flow into the fuel system via the fuel return line. If you are not sure, rebuild or replace the fuel pump.

  3. #3

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2
    Quote Originally Posted by K447 View Post
    What model and year?

    Are you turning the fuel selector valve off when you are done riding?

    You may have an air leak in the fuel system. Make sure every component in the fuel system is sealling really well.

    Pay attention to the fuel selector valve (internal O-ring seal), and the sealing at the fuel/water separator.

    The fuel pump check valves may be bleeding down (not sealing 100%) and allowing air to flow into the fuel system via the fuel return line. If you are not sure, rebuild or replace the fuel pump.
    95 sl750. It didn't do it with the stock pump, just since i put the tripple outlet on. I already went over all the seals aren't leaking. It might be the valve. I'll take a look. Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 02-22-2012, 07:52 AM
  2. just dying to hear some numbers on that 300hp fuel system.
    By theantiRXP in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-14-2012, 11:16 PM
  3. Fuel system priming
    By bigdrill777 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-19-2009, 07:11 PM
  4. Best way to prime fuel system?
    By VegasRatt in forum Polaris PWC Performance
    Replies: 26
    Last Post: 09-19-2009, 02:43 PM
  5. Fuel System Treatment
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 03-26-2006, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •