Results 1 to 2 of 2
  1. #1

    94 GTX running issues

    Had the carbs rebuilt and now my ski won't run out. If i pull the choke out a little it will rev and run but at WOT it wont do more than 40. When i got it it would do 45. Guy who did the carbs said it was a vacume issue and a low cylinder but compression is 150 on both. any ideas where to look or start


  2. #2

    Join Date
    May 2010
    Location
    Valparaiso NE
    Posts
    32
    sounds like a lean condition. better get it checked out before running any more.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX Idle/running issue??
    By Randy000 in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-01-2013, 12:21 PM
  2. Help 94 GTX running issues
    By wagondriver in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-29-2010, 08:09 PM
  3. 94 GTX with No compression in Rear Cylinder. How can it run 40 MPH?
    By JohnCiccarelli in forum 2-Stroke Performance
    Replies: 12
    Last Post: 10-14-2009, 05:43 PM
  4. 94 GTX 650 in Aussie needs help.
    By Boris in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-16-2007, 12:13 AM
  5. Results of 1st EMS/GTX run last week...
    By Red Devil in forum 4-Tec Performance
    Replies: 34
    Last Post: 01-18-2007, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •