Results 1 to 6 of 6
  1. #1

    Rxdi idles ok.. Revs up then dies

    I have a 2002 seadoo rxdi that was just rebuilt.. im not sure what blew up the rear cylinder but the cable to the oil pump from the throttle was badly frayed so.. it was changed during the rebuild.

    It had a little less than half a tank of fuel from last year. I topped up the oil then dumped about a quart (900mL) of injection oil into the half tank and topped it up with about $30 worth of premium fuel so the ratio was a little higher during break in...
    It idled fine on a trailer with a hose running to it but I took it out today for the first time to break in the motor.
    low rpms seem ok but as soon as I steadily give it throttle but not full throttle, it bogs out and dies.
    It will start right up again fine and idle but as soon as I hold the throttle down about 50% or more it eventually bogs out. It doesn't sputter or choke but it just seems to almost run out of fuel to the rail.

    I get it back and put it on the trailer but in the water so water is pumping out the front hose and then after a while, I get a "HI TEMP" warning on the gauge.... but the cylinder head isn't even too hot to touch.. Im confused.

    If water is being pumped out the front does that mean I'm far enough into the water to cool the ski ? If I can touch the cylinder wall no problem it can't really be too hot can it ?

    hopefully someone can help me...

    thanks


  2. #2

    Join Date
    May 2010
    Location
    Valparaiso NE
    Posts
    32
    The jet pump needs to be completely submerged to pump enough water to cool the motor. Just make sure it's strapped to the trailer good and tight front and rear. As for the bogging, might be the fuel pump.

  3. #3

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    who ever told you to premix a DI to break it in was a fool. you can't do that. the injection system cannot handle it. period.

    TLR

  4. #4

    Join Date
    Jan 2007
    Location
    PCB, FL
    Posts
    69
    +1
    1
    I was thinking the same thing about the premix. You are running at least a 50:1 premix plus the normal addition from the oil injection system. You don't have enough fuel to burn. I would drain the gas and start over with a fresh tank. You may want to install a fresh set of plugs as well.

  5. #5
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by BigKID View Post
    I was thinking the same thing about the premix. You are running at least a 50:1 premix plus the normal addition from the oil injection system. You don't have enough fuel to burn. I would drain the gas and start over with a fresh tank. You may want to install a fresh set of plugs as well.

    Yeah, pre-mix in a DI is not good. Drain it and start over. Change out your fuel filter and oil filter too. That is if you haven't already. If you are not using marine grade fuel your fuel filter will get clogged faster and if hard enough can starve you for fuel. You may even consider changing out the strainer in the tank. I've seen a few threads on here were they have been seriously restricted too.

  6. #6
    Turns out the boring machine was tapering my cylinder a few thou smaller at the bottom of the cylinder and in turn heating it up and causing it to fail... not to worry, the guy who did it came and picked it up and fixed it at his cost in a day... no biggie...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 RXDI won't rev up under load
    By Lk40hp in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-20-2016, 03:06 PM
  2. Replies: 6
    Last Post: 07-11-2016, 07:47 PM
  3. 2000 genesis ficht wont rev up above idle please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-11-2010, 02:03 PM
  4. SL 900 Starts up then dies
    By scorp jr in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-14-2008, 09:39 PM
  5. GP 1200 Wont rev up past idle Please Help!
    By CJean386 in forum Yamaha How To & FAQs
    Replies: 17
    Last Post: 07-03-2007, 10:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •