Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Need some help in diagnosing and fixing a problem on my 2002 gtx di 2 stroke

    Need some help in diagnosing and fixing a problem on my 2002 gtx di 2 stroke with 51 hours.
    When I attach the lanyard and start the ski, it starts ok and idles ok, problem I am having is that, when I give it some gas, it gives me one long beep, maintain on the display and the red light on the dash blinks 6 times and the 7th blink is real quick, I kinda feel like it is 6 blinks and not 7. The ski still idles ok after all that, only when I am trying to give it some gas. I have cleaned the lanyard, cleaned the terminal for the lanyard on the ski and the problem is still there.
    Any quick solutions I can try, I would like to take the ski out tomorrow for memorial day.
    Thank you all.


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by Tament View Post
    Need some help in diagnosing and fixing a problem on my 2002 gtx di 2 stroke with 51 hours.
    When I attach the lanyard and start the ski, it starts ok and idles ok, problem I am having is that, when I give it some gas, it gives me one long beep, maintain on the display and the red light on the dash blinks 6 times and the 7th blink is real quick, I kinda feel like it is 6 blinks and not 7. The ski still idles ok after all that, only when I am trying to give it some gas. I have cleaned the lanyard, cleaned the terminal for the lanyard on the ski and the problem is still there.
    Any quick solutions I can try, I would like to take the ski out tomorrow for memorial day.
    Thank you all.

    One thing I noticed is that you have 51 hrs. Now I know this may not be really whats wrong but, I haven't been able to find anything that relates specifically to your scenario of display message, buzzer, and blinking light. Plus you don't mention what happens when you give it gas. You may have a maint. reminder being displayed, at this time, because of the hours and won't get any other info till you clear that. You can download a manual for you ski in the stickies section for two-strokes. Basically, power the ski up and while the maint display is on the dash press and hold the set button for a couple of seconds till it goes away. You may have to start the ski. I don't remember exactly. It can be pretty difficult to diagnose faults because many faults share the same display , buzzer , light readouts. In the end you may consider at the very least having the dealer ship read the code/codes if you still plan to do it your self.

  3. #3
    RunRunnerRon

    Thanks for the response, I am taking it in tomorrow, the maint on the display does not stay all the time, it comes when I hear the long beep and goes away, and the ski goes back to trottle, the light also goes away, until I give it some gas again then, it gives the 1 long beep, maint on the display and the red light on the dash blinks about 6 or 7 times. I must also mention that it blows blue smoke, which it has not really done before, it has oil as the container is full, not over full but full. There are times that, i put the lanyard on, and try to start it but it does not it just beeps and display the code, once I remove the lanyard and try again it will start, but goes back to the original problem. (I can idle out and back to the loading ramp)

    Any help is appreciated.

    thank you.

  4. #4
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by Tament View Post
    RunRunnerRon

    Thanks for the response, I am taking it in tomorrow, the maint on the display does not stay all the time, it comes when I hear the long beep and goes away, and the ski goes back to trottle, the light also goes away, until I give it some gas again then, it gives the 1 long beep, maint on the display and the red light on the dash blinks about 6 or 7 times. I must also mention that it blows blue smoke, which it has not really done before, it has oil as the container is full, not over full but full. There are times that, i put the lanyard on, and try to start it but it does not it just beeps and display the code, once I remove the lanyard and try again it will start, but goes back to the original problem. (I can idle out and back to the loading ramp)

    Any help is appreciated.

    thank you.
    No prob. Wish I could be of more help. DI's can be a pain.

  5. #5

    Issue

    I have seen this before when I worked on customer other ski's. What has most likely happened is the unit has lost the programming for your key. You need to take it to a dealer and have them hook it up to buds so they can re program the dess post and key. If this doesnt work you may have an issue with the MPEM. In which case another used one from Ebay would be the route I would take. A new one is nearly $300. However the reprogram should take care of your issue. Another thing to remember if you take your battery out of your ski for a long period of time IE one or two long winter seasons this can cause this issue to re occur.

  6. #6
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by dobkins2005 View Post
    I have seen this before when I worked on customer other ski's. What has most likely happened is the unit has lost the programming for your key. You need to take it to a dealer and have them hook it up to buds so they can re program the dess post and key. If this doesnt work you may have an issue with the MPEM. In which case another used one from Ebay would be the route I would take. A new one is nearly $300. However the reprogram should take care of your issue. Another thing to remember if you take your battery out of your ski for a long period of time IE one or two long winter seasons this can cause this issue to re occur.


    I'm curious then how the ski would even be able to start if the Mpem has lost the programming for the key? Plus a new Mpem is anywhere from a $1000-$1500 bucks. Not $300. Used is more like it.

  7. #7

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    Try simple things first. change the spark plugs, drain the old gas and refill. the blue smoke may be the fogging oil if you winterized it.

    TLR

  8. #8

    Follow-up

    So far I have changed my spark plugs, the issue was still happening, I remove the plug wires, open the box that the plug wires run to and disconnect those also, let it sit for a bit, then start it again, it started up and reve withou any issues. I am going to take it to the water tomorrow, and try it from the loading ramp with the ski still attached to the trailer and see what it does, if that works ok, I will then take it out for a few spins and see what happens.

    A few things I noticed:

    When I looked inside the grate towards the impeller, there is a fishining line wrapped around the pipe that goes into the impeller.

    When I shine a light from the back off the ski and look into the rear wring from the grate, I can see daylight around the sides of the impeller, I read somewhere that it is not a good sign to see light through that. Does that need changing, and is it something easy to do?

    Thanks for all your replies.

  9. #9

    Join Date
    Jan 2007
    Location
    PCB, FL
    Posts
    69
    +1
    1
    What is your battery voltage while the ski is running? Check your battery connections to be sure they are clean and tight. Sounds to me like an intermittant low voltage issue.

  10. #10
    Quote Originally Posted by RumRunnerRon View Post
    I'm curious then how the ski would even be able to start if the Mpem has lost the programming for the key? Plus a new Mpem is anywhere from a $1000-$1500 bucks. Not $300. Used is more like it.
    The issue I believe is not the key. If the MPEM has a glitch in the fuel map protocol then it would not communicate properly with the ski. I told him to take the key and unit so they could reprogram the MPEM and then would subsequently have to reprogram the key to work with the ski. I think my post on this was vague due most likely to my lack of sleep lol

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 05-19-2015, 09:04 AM
  2. Replies: 1
    Last Post: 01-03-2011, 01:57 PM
  3. need some help in getting parts please!!!!!!!
    By MysssticGhost in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-16-2008, 07:58 AM
  4. Need some help in CT.
    By rxtscott in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 04-23-2008, 06:50 PM
  5. Hello, I'm new here and need some help....
    By RXP Keith in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-19-2007, 06:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •