Results 1 to 7 of 7
  1. #1

    Question cavitation problem please help r12x

    installed new jet pump,solas 17/29 impeller & r&d intake grate on my r12x.and now it cavitates more than it did before i installed the new parts.anyone have any ideas please help.


  2. #2
    Did you seal the intake grate off just as good as it was before?

  3. #3

    Question cavitation problem please help r12x

    yea it sealed completly i didnt do the work braword motor sports of wpb fl did the work but i looked at everything and its all sealed with silicone.if i hit it from a stand still it will cavitate like crazy but if i go easy on it and moving first than hit it it will only go up to 40mph and cavitate again.

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by emanueldelgado View Post
    yea it sealed completly i didnt do the work braword motor sports of wpb fl did the work but i looked at everything and its all sealed with silicone.if i hit it from a stand still it will cavitate like crazy but if i go easy on it and moving first than hit it it will only go up to 40mph and cavitate again.



    A few things you can check

    1. look under ski and see if the "rubber" nose cone on end of prop was used, if the solas one was used that could be a problem.
    2 Look under ski at intake grate....if its R&D it probably hangs below the fiberglass hull and that also could be a problem.
    3 if they pinched the oring between the "thrust plate" and the pump that could be a problem.


    when you let people who don't work on Honda watercraft everyday work on your ski.....these things can and will happen.....you probably could have done a better job yourself!

  5. #5

    cavitation problem please help r12x

    your probably rite about me doing a better job but i thought that the dealer would know what there doing.but at least i have someone to blame and not myself lol.so your saying that if the stock cone and the solas cone are both installed that will cause a problem?because i can see the rubber cone but i cant see the solas cone but im thinking that he installed both only because the solas prop came with a cone.

  6. #6
    Dave Sharp dav_dman's Avatar
    Join Date
    Aug 2005
    Location
    louisville Ky/so. IN
    Posts
    1,453
    +1
    1
    check your wear ring clearance. Did you change the prop "at this time" because the stock prop was damaged? If so, then the wear could have been damaged as well. How many hrs on it? I've got 130 hrs on my wear ring and its still good so maybe thats not it but you might check.

    The RD grate i had did suck

  7. #7

    Question cavitation problem please help r12x

    my ski has 157hrs on it.stock it ran fine just on take off wot it would cavitate a little but than get moving.i had it checked out and was told that it was the clearance between jet pump & prop.that is why i installed new parts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kawasaki 12-F problems...... please HELP
    By 0ne8one in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 10-25-2007, 12:50 AM
  2. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  3. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM
  4. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •