Page 1 of 11 1 2 3 ... LastLast
Results 1 to 10 of 105
  1. #1

    Motor is locked up! 04 RXP

    Hey guys:

    I have a 2004 RXP

    Mods:
    X-Charger
    42lb Injectors
    14/19 w/ anti cavitation cone

    Was riding the ski, i heard almost what sounded like some sort of grinding sound, ski very quickly came to a halt and the motor shut down (matter of 2 or 3 seconds). Now when i try to start the ski, it just kind of clicks like it has a dead battery.

    What I've checked:
    Supercharger (pulled intake off and made sure the supercharger didnt spin)
    Pump (Pulled pump and tried to start it)
    Water Ingestion (pulled spark plugs to see if water came out when cranked; none)
    valve cover (pulled valve cover off, everything looks to be in order - timing chain in place, no loose springs)
    spark plugs (all have normal coloration)

    What could be wrong? how much is this going to cost me? Anyone want to work on my ski in SE PA for $ and beer?
    Last edited by radeon; 06-02-2010 at 06:44 AM.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Remove your SC to see if it's locked down!

    How many hours on the motor - charger??? What do the plugs look like... any damage to them???

  3. #3
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    Dropped Valves??

    Might have to pull the head off to check.

    That would be my guess.

  4. #4
    Quote Originally Posted by BigDaddyRXP View Post
    Remove your SC to see if it's locked down!

    How many hours on the motor - charger??? What do the plugs look like... any damage to them???
    Plugs looked just fine
    Motor has 125hours on it
    XCharger has ~5hrs on it

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Pull your charger first! If it spins freely... then you have major problems Like Rick said... valves would be my next guess if your charger spins when removed However... if your plugs look good Keep us posted!

  6. #6
    rxp1972's Avatar
    Join Date
    May 2010
    Location
    GREECE
    Posts
    125
    Probably the bearing from the sc.Or the clutch is broke.

  7. #7
    Quote Originally Posted by rxp1972 View Post
    Probably the bearing from the sc.Or the clutch is broke.
    on an x charger with <5 hours on it?

  8. #8
    rxp1972's Avatar
    Join Date
    May 2010
    Location
    GREECE
    Posts
    125
    why not!!!!!! i have seen lot of crazy things.
    Just pull out the charger and make a wish not to be this.

  9. #9
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    Quote Originally Posted by rxp1972 View Post
    why not!!!!!! i have seen lot of crazy things.
    Just pull out the charger and make a wish not to be this.

    I would be praying to god its the charger as by the sounds of it its going to be the cheapest thing to repair.

    But i would bet money on it that it is the valves.

  10. #10
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,548
    +1
    4,766
    Grinding sound is not good, but you never know...
    I was flying across the lake last year and my RXT cut off on me like that and wouldn't start. I took it to the dealer expecting the worst, and after all that it turned out to be a fuse....

Page 1 of 11 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need to lift/jack up '04 RXP off of trailer, suggestions?
    By JetmechF16 in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-15-2013, 07:18 AM
  2. Replies: 5
    Last Post: 10-28-2012, 07:52 PM
  3. How to set up 04 RXP for wakeboarding
    By NZ_Dave in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 07-31-2011, 11:36 PM
  4. 03 gtx 4tec motor the same as 04 rxp?
    By vegtech in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-07-2011, 12:11 AM
  5. steering locked up ...05 RXP
    By Masterz in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-22-2009, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •