Results 1 to 4 of 4
  1. #1

    Help..Riddle me this, ski stopped working and took on water - New owner here

    Guys,

    Hello.

    Rode the Ultra 250x (2007) hard the last day at the river. This is the first time as a new owner of the 250x to take the ski out (other than the test drive)

    Worked great all day, did a fast 26 mile ride, it was glassy.
    Fuel warning came on, no problem right? Next thing I know ski is running TERRIBLE. Bogging down, wont go over 1,500 RPM.

    I pulled into the Marina thinking that this was a safety feature of the ski once the gas gets very low. I filled it same results

    I changed the plugs..same results. As I am changing the plugs I realize the engine bay is 1/2 full of water!! WTH?

    Drain it, barely get it on trailer, 6 hour drive home. Fire it up and it is back to normal.

    Huh?

    Any help is GREATLY appreciated.

    T


  2. #2
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    Quote Originally Posted by troye View Post
    Guys,

    Hello.

    Rode the Ultra 250x (2007) hard the last day at the river. This is the first time as a new owner of the 250x to take the ski out (other than the test drive)

    Worked great all day, did a fast 26 mile ride, it was glassy.
    Fuel warning came on, no problem right? Next thing I know ski is running TERRIBLE. Bogging down, wont go over 1,500 RPM.

    I pulled into the Marina thinking that this was a safety feature of the ski once the gas gets very low. I filled it same results

    I changed the plugs..same results. As I am changing the plugs I realize the engine bay is 1/2 full of water!! WTH?

    Drain it, barely get it on trailer, 6 hour drive home. Fire it up and it is back to normal.

    Huh?

    Any help is GREATLY appreciated.

    T
    sounds like you popped off a thru hull hose. There are hoses at the back of the ski, just above the jet pump. Check that they are all on and tight. Happened to me before.

  3. #3
    I will take a look Red, thank you

  4. #4
    mirror's Avatar
    Join Date
    Jan 2006
    Location
    Seminole, FL
    Posts
    532
    +1
    3
    Yes it is Kawasaki tradition to have the hose pop off and try and sink them on the first rides, happened to me. I believe those machines also have the exhaust come apart sometimes but don't really know much about them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. riddle me this (rxp top speed???)
    By robby212 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 03-22-2010, 01:19 PM
  2. riddle me this????
    By killcraft in forum Polaris Open Discussion
    Replies: 4
    Last Post: 02-23-2010, 06:18 PM
  3. Riddle Me This...
    By CrazyA in forum Polaris Open Discussion
    Replies: 2
    Last Post: 12-01-2007, 03:06 PM
  4. Riddle me this...Oil Issue AGAIN....
    By Ultra Junkie in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-16-2007, 10:04 AM
  5. So a Lady brings me her skis to work on.....
    By QuickMick in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-29-2006, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •