Results 1 to 8 of 8
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    Wear ring and drive shaft

    Ok i looked underneath the ski where the intake grate should be and noticed a small gap between the wearing and the hull is this normal or should i remove everything and redo the silicone and reinstall until the housing is completly flush with hull? i will attempt to take a pic when i get home tonight.

    i meant wear ring and hull lol.... (jetpump Housing)


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Russ,

    It helps if you post pictures of what you are seeing

  3. #3
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Ya i will just currently at work atm will post pics when i get home.

  4. #4
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Picture

    its not the best but you can see the little gap

    also im sure you cant tell but is the impeller to close to the wear ring? should there be a larger gap there as well?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SDC10636.jpg 
Views:	81 
Size:	53.1 KB 
ID:	191305  

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Hard to tell from the photo how large that gap is between the pump base and the hull. The seal between the pump and the hull must be air tight - no air leaks at all.

    The impeller blades are supposed to be very close to the wear ring.

    Maximum blade clearance specification is .020 inches, and .010 inches or less clearance to the wear ring is considered good.

  6. #6
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    should i redo the whole thing or should i just dab some silicone in the gap to make sure it is air tight.

  7. #7
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Is it ok to just tighten the top bolts down a little more and apply some silicone to the small gap?

    i was going to go in there and change the impeller back to the stock impeller so ill be in there anyway =/

  8. #8
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Top

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 sportster 650 need pto and drive shaft
    By friday280 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 08-10-2007, 06:35 AM
  2. Clearance between wear ring and prop?
    By meeper in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-26-2007, 09:55 AM
  3. Prop, wear ring, and SS washer install
    By MikeB in forum Southeast
    Replies: 3
    Last Post: 02-28-2007, 10:03 PM
  4. wear ring and impeller ????
    By BJTKRXPHD in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-22-2006, 06:34 AM
  5. Question about SS wear ring and bearing mods...
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-11-2006, 06:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •