Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    1999 ultra 150 60lbs compression (any thoughts?)

    I have a question. I got my ski out for the first time this year and took off ran great for about 1 minute then lost power. starts right up and idles fine try to get up on plane and it will not do it. I pulled the plugs and did a compresion test. i am only getting about 60psi. Motor actually sounds good when out of the water. I called the dealer and they told me it needs a new motor $3000.00. They said they will not rebuild a pwc motor. Any thoughts? Please help!!!

    thanks


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Sounds like its time to find a new stealership Did it have 60lb on all 3 or just 1.One common problem is cracked oil lines taking out a cylinder. A rebuild is no big deal you can dio it yourself. There are lots of us here that can help walk you through it. Do you have a service manual for it?

    Welcome to the board.

  3. #3
    all three cyclinders are checking 60 psi. I have worked on many motors in the past and have never seen or heard of all the cylinders going down at one time, something just does not seem right. I am going to tear it down this weekend.

  4. #4
    pokechop2006's Avatar
    Join Date
    Jun 2009
    Location
    summerville sc
    Posts
    223
    feel underneath the block for cracks,ive heard they will still run with a hole in the bottom,morris is the man for your answers for sure.

  5. #5
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Yep I have ventilated some ultra cases. I would try a new gauge before I dove in. 60 psi in all 3 just sounds too odd. Then I would start by pulling the heads and have a look at the pistons and cylinders. I assume you are checking with the throttle wide open and a hot battery.

  6. #6
    yep new battery and 2nd compression gage. I will check for cracks in the block.

  7. #7

    Join Date
    Aug 2009
    Location
    Yorkville, IL
    Posts
    75
    Did you fog the motor before winter? Sounds like your rings rusted to the walls and the rust tore up the cylinder/ring seal once you got it running. The only way to verify is to pull the heads to check the cylinder and the cylinders to see the rings. That is the only thing I can think of that would cash 3 cylinders after a long time of sitting.

  8. #8
    I did fog it but I only pulled the plugs and sprayed in the cylinders. I did get the heads off and nothing is obvious. i am going to pull the cylinders off tomorrow. The one thing that i thought looked a little funny was the head gaskets. They were not blown out but looked like they were not sealing very well. I am almost tempted to throw new gasket on a nd do another compression test.

  9. #9

    Join Date
    Aug 2009
    Location
    Yorkville, IL
    Posts
    75
    If the gaskets were not sealing well, it may have leaked water from the water jackets into the cylinder causing the rings to rust as well.

  10. #10
    Ok I pulled everything except the cylinders. I have oil everywhere on this thing. the cylinders look good, it does look like they are sleeved cylinders. Will this engine come out? Is there something I should know to get this engine out. Since I am this far into it, I was thinking of taking the motor out to check for cracks on the lower end and change out the gaskets. Also I would like to find out where this oil is coming from. I am leaning toward rusty rings.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Ultra 150 for sale 35hrs
    By Duane Hawley in forum Kawasaki Skis
    Replies: 1
    Last Post: 11-12-2008, 09:50 PM
  2. Will A 2001 Cdi Box Work In 1999 Ultra 150
    By macattack in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-09-2008, 06:24 PM
  3. '04 Ultra 150 Repairs needed! Any advice?
    By cjb4lsu in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-29-2008, 09:50 PM
  4. value of 1999 ultra 150
    By txgp1300r in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 03-07-2008, 01:11 AM
  5. Possibly getting 01 ultra 150.. quick compression question...
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 07-31-2007, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •