Results 1 to 4 of 4
  1. #1
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123

    Installing R&D Heads

    Has any one installed these on their gp1300r? Any tips when doing it would be awsome. And another question, do i need new pistons or the OEM ones will do, ive read that those are the best ones to use.

    Thanks.


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by blam3d View Post
    Has any one installed these on their gp1300r? Any tips when doing it would be awsome. And another question, do i need new pistons or the OEM ones will do, ive read that those are the best ones to use.

    Thanks.
    http://www.rivamotorsports.com/instr...s/ry100313.pdf

    search a little more on here about alternative water routing

    oem is best for pistons imo

  3. #3
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    OEM is just fine! No worry. New head gasket or if yours is low hour should be ok? Depends Normal tourqe specs. Enjoy

  4. #4
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123
    my 03 has 116 hours.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing speakers/amp on ski
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 38
    Last Post: 10-23-2009, 10:36 PM
  2. installing wet pipe and head on 04 sxr
    By born riding in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 01-14-2008, 03:05 PM
  3. NEED HELP, I'm installing R&D Red Heads
    By turbocycle in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 11-28-2007, 12:03 PM
  4. help installing greater yamaha 701 head pics needed
    By jetman46 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-07-2007, 08:17 AM
  5. How to install the amp/speakers in the waverunner
    By picaflor in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 05-18-2007, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •