Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 58
  1. #1
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19

    the sl1050.. the pain in my.....

    ok so as some of you know, i have a 97 sl1050 that i got last summer, and after the cdi crapped out it has given me nothing but problems..

    i had the updated ignition installed and the thing has fresh rebuilt carbs, new fuel lines and i bypassed the fuel switch for now...

    there are two issues with it right now...


    1) it has a bog on the bottom end.. you can work past it by playing with the gas, i have bypassed the on/off valve and also the water seperator.. and nothing changed so i no have the seperator hooked back up..

    i have a little bit of air in my lines and i have no idea where its coming from.. i checked the tank and the fuel sender, i played around with fuel lines and ended up having two switched but that did not help at all..

    i have run it like this for a bit, and i know plugs are not eh best way to check for lean but they look fine.. i haent got a chance to check piston wash yet..

    as long as i get away from the bog she pulls hard and will run fine, no bog up top, i was told to try and adjust the lows a bit to see if that helps.. im going to try this,

    2) the second issue is.. it is hard to turn at speed.. so when i replaced the stock steering with the umi i got from lugs, it did not chance so i am led to think the cable is going bad..

    but its a newer cable and was fine at the end of the season so im not sure what is going on with that but i will have to look into that a little more..


    i need to get this running good enough to race it in july. and at this point i might ether have to enter the paddle boat or my 3 seater..
    Last edited by ryandi2; 06-04-2010 at 07:01 PM.


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    The bog will never go away with the 97 carbs you need to update to the 98 or newr 40's with the accelarator pump

  3. #3
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    but i never had this issue last year.

  4. #4
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    404

    stacks

    the lako stealth stacks were made with this ski in mind to cure the low end bog.got a set 30.00 shipped.if you increased the pump nozzle size the steering can get harder at speed

  5. #5
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    the pump is stock..

    and do you have pics of these?

    im just puzzled at the fact that it did not have bog before hand..

  6. #6
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    404

    lako stacks

    check the are these worth a damn post in the general discussion area

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by TxPro1200 View Post
    check the Are these worth a Damn? post in the general discussion area
    Are these worth a Damn?

  8. #8

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    maybe an air leak in the cases ?

    seems like if he changed the pilot jets to something bigger it might get up and go faster ,

    have you tried playing with the choke ?

    thought of changing the rack off your running sltx to see if its in the carbs

  9. #9
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    Quote Originally Posted by Bone1050 View Post
    maybe an air leak in the cases ?

    seems like if he changed the pilot jets to something bigger it might get up and go faster ,

    have you tried playing with the choke ?

    thought of changing the rack off your running sltx to see if its in the carbs

    i dont think its a leak.. in the cases, i can see air in the lines..

    i could get bigger jets.. but the motor is stock.

    the choke kills the engine, does not make itrun any better

    i thought about it.. but id rather not mess with that if i dont have too..

    if i dont get this 100% its going back to where i got the carbs rebuilt and have them look at them again..

  10. #10
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19

    trim motor

    my trim never worked when i got the boat, so jmf1 (jeff)hooked me up with a trim motor out of a 750, perfect fit and works out of the water.. have not water tested it yet since i just did it..

    i opend up the ebox to see tones of wires and the two for the trim where in a nice gromit and i did not want to cut it out.. and i did not want to slice the wires together for fear of corrosion, so i took the motor apart to see water in the bad trim motor (go figure) and the wire ends where just sliped on the top of the motor using some sort of clip at the end, so i switched them around! and no worrys with cutting the wires all upp!

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Love the pain from my frist ride -2009 season!
    By DigitalCSI in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2009, 12:01 PM
  2. Love the pain from my frist ride -2009 season!
    By DigitalCSI in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-04-2009, 09:50 PM
  3. HELP! How do I take out the waterbox in my Speedster??
    By FastSpeedster215 in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 07-26-2008, 02:19 PM
  4. Nervous about the antifreeze in my cooling lines.
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 01-19-2007, 01:19 AM
  5. changing the oil in my truck today...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-01-2006, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •