Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120

    '94 slt 750 !!!!!!!

    '94 slt 750, new carb kits, new triple fuel pump, 124m-128c-128p compression, crank has perfect 120 degree index, i cant get the bog out of it, from idle i have to feather the thottle and pump the primer atleast twice, then it will go. I noticed when rebuilding the carbs, it has 75 low jets, and 110 high jets, should'nt it have 90's in the high?? It also has an orange spark, not the snappy blue spark my '95 has.
    i'm to the point of giving up on it. HELP NEEDED!!!


  2. #2

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    Ok, opened the electric box and WOW! What a mess, wire nuts, tape, cheesy terminal ends, a total mess!!

  3. #3
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    Yes #90 main jet on the 38mm mikuni, as far as the orange spark its my understanding that indicates electrical issue, you want a good blue spark.Also check your plug wire ends, cut them back around a 1/4 in. screw boots back on & zip tie.
    Good Luck Brian

  4. #4

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    plug wires are cut, elec. box is cleaned up, all new ends, the machine idles smooth at 1300rpm, runs up to 6180rpm, just cant get the bog out of it from idle????
    I'm curious as to why the previous owner installed 110 jets? The carbs are black, the rest of the engine is blue, my 95 has blue carbs.

  5. #5
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    have you adjusted the low speed screw on each carb a little more open? did that not make any improvement? is the pulse line at the fuel pump clear of any crankcase oil huh? that can clog with fuel/oil mix and clog the pulse. you can blow easily from the fuel in line to the pump all the way back to the fuel outlet from the fuel tank huh? did you check pop-off pressure? too high and it'l bog and bog and bog. it can be one thing. it can be a combination of things.

    the pump is relocated in its new low to the hull position huh? with the pulse line as short as possible?

  6. #6

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    I have adjusted the carbs till my fingers hurt, ALL fuel lines are free and clear, and are all new, including the pulse and intake lines.
    Fuel pump is in it's stock location, the pop off has not been checked, it has the factory springs in it.

  7. #7
    Un- bolt the fuel pump and lay it in the bottom of the hull ---for a test----Easy !!!

  8. #8

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    Ok, tested with pump laying on the floor, same symtoms.

  9. #9
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    What color are the springs? You have or have not checked pop off ?
    10-18 lbs is what your after.

  10. #10

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    They look to be a grey or silver color. I have not checked pop off, need to get a tester.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 slt 750
    By keng in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-02-2007, 10:59 PM
  2. 94 SLT 750 - Primer Installation
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 16
    Last Post: 07-29-2007, 09:31 AM
  3. 94 slt 750 fuel question
    By ace16a in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-08-2007, 11:10 PM
  4. 94 slt 750 problems
    By ace16a in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-28-2007, 03:45 PM
  5. '94 SLT 750...deal or no?
    By Fish Man in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-22-2007, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •