Results 1 to 5 of 5
  1. #1
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1

    Thought I lost the Clutch Sunday???

    Last post, for the next few hours.

    I was playing around and doing some dumb ass tricks, (standing on the side of the boat backwards doing circles and the boat sputtered)
    I got on correctly and opened up a little to clear it out and it almost died. I rode it easily back and forth. Opened it up and it would only go 5000rpm's. I kept trying and it got to 7500.
    After a few minuets, it got back to 8000.
    It felt as though the SC clutch gave out, and came back??

    Any ideas???


    David


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,981
    +1
    1,899
    That was your TOPS sensor coming into play.

  3. #3
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Does it take it a little time to clear up?

    Do I need to do anything if it happens again, such as turn off and let the oil drain back down??

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,981
    +1
    1,899
    When it used to happen to me i would just sit and idle for about 15 seconds or so then take off slowly.

  5. #5
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    yea..it just sputters for a few seconds..happens to me a lot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thought I blew up the clutch this weekend
    By Lurker in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-26-2005, 11:42 PM
  2. Lost supercharger clutch this weekend
    By hdsilverado in forum 4-Tec Performance
    Replies: 156
    Last Post: 07-25-2005, 02:48 PM
  3. Replies: 2
    Last Post: 07-19-2005, 10:32 PM
  4. Lost ANOTHER clutch today!
    By Green Hulk in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-04-2005, 12:50 PM
  5. lost my clutch today
    By Green Hulk in forum 4-Tec Performance
    Replies: 30
    Last Post: 06-14-2005, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •