Results 1 to 4 of 4
  1. #1

    No spark 96 SL 900

    Hi all. I just picked up 2 SL 900s that won't start. I have been reading thru the posts here and gotten some great info on how to get started troubleshooting the issue. I currently am not getting a spark, checked voltages at battery terminals and am getting 10.8 while cranking opened up the CDI and tested at the red/purple lines and getting the same accross the board except on one terminal where the fuse is connected, I am getting 1.3 there. Is this typical or would this possibly indicate a bad fuse?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Fuses do not provide power to the CDI ignition module. What you opened up was the electrical box. The CDI module is inside that box.

    Click the links below for more info;

    Polaris Domestic (red) engine

  3. #3
    Oh man do I feel dumb now. Thanks for the info. I am a novice at this, these are the first machines Ive ever bought let alone worked on. I will check the right spot this weekend.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    We all started somewhere with these things

    Welcome to the Hulk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Have a few ??'s about a recently purchased 96 sl-900
    By gvnitup in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-11-2007, 09:46 AM
  2. Is a 96 sl-900 worth 550 ?? Top-speed???
    By gvnitup in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-07-2007, 06:29 PM
  3. 96 sl 900
    By mixedguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2007, 05:38 PM
  4. Where can I get a deal on parts for a 96 SL 900???
    By Alberta Boy in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-18-2007, 01:25 PM
  5. 96 SL 900 CDI and stator
    By S12L00X in forum Polaris PWC Performance
    Replies: 0
    Last Post: 03-13-2007, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •