Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2010
    Location
    Melbourne, Australia
    Posts
    2

    I have some questions about my Kawasaki Ultra 250x

    Hi guys,
    I have just purchased a used Kawasaki Ultra 250x. I has only done 28 hours, great condition, it has been really well looked after.

    I rode it over the weekend for the first time. I have a few questions and would appreciate if anyone can help

    1. There only seems to be a small amount of water coming from the bypass outlet. Is this normal. I was under the impression that it should spray out quite hard. Instead it just seems to trickle out

    2. Run on- It seems to have a fair bit of run on. I am aware the Kawasaki's have that built in but even when I rev it on the trailer, it runs on a fair bit. It's not an issue at low speed, I know the throttle is not sticking as I have watched the carby return straight away.

    3. The front storage compartment (tray) holds a fair bit of water. Can this hatch be adjusted so the rubber seals a bit better?

    4. the boost PSI only reaches 10. Is this normal. It has up to 15 PSI on the guage but it gets nowhere near that

    Apart from that, an awesome ski.

    Look forward to hearing from people



    Also, does anyone have an electronic version of the service manual they can send me?


  2. #2
    H20 addicted Blu_Boost's Avatar
    Join Date
    Sep 2008
    Location
    Lake Havasu,AZ
    Posts
    302
    1. It depends what RPM range your in. If your on the trailer than its gonna be a trickle. But if your WOT (wide open throttle) it should be shooting out lots of water.

    2. Completely normal for me at least. I think it has to do with maneuvering at slow speeds.

    4. Yes its a factory BOV, so its set somewhere around 10ish. BOV block-off will help you out somewhat but it voids warranty i believe.

    The ultra is a good ski if its well maintained. Checks all your oils and change them every 25 hours.
    Good luck on the service manual "eletronic" or "free"

  3. #3

    Join Date
    Jun 2010
    Location
    Melbourne, Australia
    Posts
    2
    Quote Originally Posted by Blu_Boost View Post
    1. It depends what RPM range your in. If your on the trailer than its gonna be a trickle. But if your WOT (wide open throttle) it should be shooting out lots of water.


    4. Yes its a factory BOV, so its set somewhere around 10ish. BOV block-off will help you out somewhat but it voids warranty i believe.
    Thanks for the reply Blu,
    I think I might have to take it to the dealer to check for a blockage. Even at full speed it doesn't shoot out lots of water.

    Its already out of warranty so I will look into the BOV block off

  4. #4
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    It should not run on, if you are talking about engine run on. Maybe bad fuel?

    Block of bov and any chance of a boost leak is eliminated from the valve anyways. Also check/tighten all hoses. This includes water, exhaust, and air lines.

    Water in compartment: Do a search on here. There is a recent thread about adding more weatherstripping.

    Water should be spraying out of the nozzle at a pretty good rate when riding.

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by Trento View Post
    Hi guys,
    I have just purchased a used Kawasaki Ultra 250x. I has only done 28 hours, great condition, it has been really well looked after.

    I rode it over the weekend for the first time. I have a few questions and would appreciate if anyone can help

    1. There only seems to be a small amount of water coming from the bypass outlet. Is this normal. I was under the impression that it should spray out quite hard. Instead it just seems to trickle out it sounds fine to me but if you are worried blow compressed air in the but be careful!!

    2. Run on- It seems to have a fair bit of run on. I am aware the Kawasaki's have that built in but even when I rev it on the trailer, it runs on a fair bit. It's not an issue at low speed, I know the throttle is not sticking as I have watched the carby return straight away. off the throttle steering is the first answer. they all seem to do it at some stage more so if you hava played with the timing. by the way no carby on this ski just a throttle body

    3. The front storage compartment (tray) holds a fair bit of water. Can this hatch be adjusted so the rubber seals a bit better? seal the top lip of the bucket same as the bottom with the sticky sided foam, commercially available

    4. the boost PSI only reaches 10. Is this normal. It has up to 15 PSI on the guage but it gets nowhere near that normal with stock pulley

    Apart from that, an awesome ski. agree

    Look forward to hearing from people



    Also, does anyone have an electronic version of the service manual they can send me?
    yes there is one getting around

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i have a question about my sc.........
    By johnrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-15-2011, 12:56 PM
  2. Replies: 2
    Last Post: 05-02-2011, 03:36 PM
  3. New to site, new to area, have some questions about rxp
    By 20rxp04 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 12-15-2008, 10:00 AM
  4. I have a question about my 02 f12x
    By pclynch1974 in forum Honda Open Discussion
    Replies: 1
    Last Post: 06-12-2008, 05:58 AM
  5. Have a question about my nuts
    By The Bandit in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-14-2006, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •