Results 1 to 2 of 2
  1. #1

    Join Date
    Aug 2008
    Location
    myrtle beach
    Posts
    28

    2000 gtx rfi fouling plugs like crazy

    The ski runs great with fresh plugs but if I have to go thru any no wake zone within 5 min of running after I start bogging down and it wont restarts. It loses 200rpm right after getting back in the throttle then declines within the 5 min or so. Why is this happening?


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    check your oil injection. make sure that the cable is in good shape and that the pump is indexed properly. if the cable breaks or comes off the reel, the pump defaults to wide open. this added oil at idle will foul your plugs quick.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 GTX RFI Fouling 1 plug
    By Muzzleloader in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-07-2013, 07:17 PM
  2. NEED HELP! 2000 gsx rfi fouling plugs
    By dodgeman97 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-27-2011, 11:57 AM
  3. 2000 gtx rfi starting issues
    By vodomagoo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2009, 01:06 PM
  4. cant start a 2000 gtx/rfi 800
    By mibunkerking in forum 2-Stroke Performance
    Replies: 7
    Last Post: 04-07-2009, 07:11 PM
  5. What Are Some Good Mods For a 2000 GTX RFI
    By jcohen17 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-14-2008, 12:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •