Results 1 to 5 of 5
  1. #1
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61

    1999 slx 1050 no spark

    We have a 99 SLX 1050 that's getting no spark. We replaced the CDI with another brand new original box but still no spark. Any help would be greatly appreciated.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Did you test the stator?

    Why not install the Ignition Update Kit?

  3. #3
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    Our mechanic said the update would be more costly for both the parts and the instal. We figured if the original CDI lasted for 11 years that a replacement would too. How do you test the stator?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by h2jim View Post
    Our mechanic said the update would be more costly for both the parts and the install.

    We figured if the original CDI lasted for 11 years that a replacement would too.

    How do you test the stator?
    It is only less expensive if the problem diagnostic was correct and the original stator is still good.

    There is a reason Polaris issued the Update Kit, and that reason was reliability.

    Polaris Domestic (red) engine

    How do I test old and new domestic red engine CDI, Magneto and Ignition coils?

    BTW, make sure the problem isn't something basic like a weak battery or incorrectly connected wires inside the electrical box.

  5. #5
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    We rode April 2nd and it worked great. Tries to fire it up 2 weeks ago and no spark. I would think the wiring is ok? How do I check the stator?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Polaris SLX 1050 - Weak Spark??
    By shornback in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 11-05-2011, 09:46 PM
  2. Need help, 1999 SLX 1050 no spark
    By dustin88 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-18-2010, 12:30 PM
  3. 1999 SLX 1050 has weak spark
    By oachs83 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 09-21-2009, 04:43 PM
  4. 99 SLX 1050 No Spark in Front Cylinder
    By fastazu in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-22-2007, 02:21 PM
  5. 96 SLX 780 No Spark
    By Truckinevan2005 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 04-30-2007, 10:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •