Results 1 to 9 of 9
  1. #1

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    1994 750 polaris

    Can anyone tell me why I have excess fuel coming from the venturi even after I shut the motor off? I had my ski on the trailer at a fairly good angle just to get the jet in the water and the rear cylinder would not fire, it had spark, the plug looked new as in no color at all. I am wondering if there is something wrong with the carb?


  2. #2

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    more info

    I have my lows at 1 1/4 turn and my highs at 1 turn. Could it be a check valve problem or a popoff problem as it is a low throttle?

  3. #3
    Saving the Manuals every day.. TheBlueMartin's Avatar
    Join Date
    May 2009
    Location
    Pure Michigan
    Posts
    488
    +1
    1
    Sounds like you have a bad o-ring in one of your jets, or the needle face isn't making proper contact with the seat.

  4. #4

    Join Date
    Dec 2009
    Location
    Alvin,TX.
    Posts
    120
    i would think excess pressure in the fuel tank?

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Quote Originally Posted by gregr1971 View Post
    i would think excess pressure in the fuel tank?
    That can do it.

    Make sure your tank vent is working.

    Also turn your petcock to off when not in use. That's what it's for.

  6. #6

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    the Blue Martin wins

    Thanks guys, I went through the jets and sure enough the high jet o-ring was split. All cylinders are firing but I don't have much force. The motor is working well but I'm just spining my 'tires', any help?

  7. #7

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    cool site

    I just watched km447 video on solving problems. I must have more then one problem. The basics are simple; spark, fuel and air, but it can be fun working on used skis that aren't working. I didn't realize these triples will start on one cyl. I am going to have to make sure all cylinders are firing. Great site with a lot of info, thanks to all that make it possible.

  8. #8

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    never mind but the spinning tires

    I shouldn't ride i a swamp... too many weeds.

  9. #9
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    Quote Originally Posted by Frozen View Post
    I have my lows at 1 1/4 turn and my highs at 1 turn. Could it be a check valve problem or a popoff problem as it is a low throttle?
    94 750 fuji w/ 38mm mikuni factory settings are,
    hi side 1 1/4 mag, center 3/8 pto 7/8
    low side 7/8 all cyl.
    pop off pressure 10 - 18 p.s.i.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 95 polaris sl 750 to 1993 sl 650 jug swop..?
    By onthewater in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-14-2013, 11:09 PM
  2. 1994 SLT 750 Polaris running to rich
    By tommy73 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 04-21-2009, 09:34 PM
  3. FS 1995 SLT 750 Polaris
    By jarcynvicnchris93 in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-05-2008, 08:02 PM
  4. Need parts for 95 SLT 750 Polaris
    By ikuspalatinus in forum Polaris Classifieds
    Replies: 3
    Last Post: 05-08-2008, 10:29 PM
  5. 1994 750 sl reeds
    By scotty2hotty in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-09-2008, 12:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •