Results 1 to 6 of 6

Thread: HELP

  1. #1
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61

    HELP

    Does anyone know of a good Polaris machanic in the Toronto area? My son bought a 99 SLX and has no spark. We replaced the cdi but still no spark. Our mechanic can't fix it and I am not good with the electrical end of skis. I have called every Polaris dealer from Ottawa to Toronto and nobody will touch it. I don't want my son to get discouraged and be done with pwc's. He saved his money and bought this machine. It worked great all last year and the first ride if this year and now no spark. Please help before he gives it up.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    What's the battery voltage (measured at the battery) while cranking? It MUST be at least 10.6 while cranking, anything less will not allow the ignition system to fire off.

  3. #3
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    First thing we checked. Lots of battery.

  4. #4
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    when you upgraded the the sator did you upgrade the cdi?

  5. #5

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127
    Make sure all cable inside the cdi area connected properly. Also make sure that the cables on the spark plugs are working properly either they got disconnected inside the CDI or the cables are bad and need replacement. cut them down a little and try again. keep us updated.

  6. #6
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    just had the same problem on a virage, bought a cdi and stator and starts right up now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •