Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    Pro 785 acting strange today

    I took out the Stock pro 785 and the old SL750 out today, everything seemed OK with both, but when my wife was on the pro785 it kept dying on her about 50 yards off the pier, I went out and got her, It was being tempermental, it would run a while fine, then bog down and die,
    It seemed like it wasent getting spark or the kill swith was pulled,
    I switched pull cords with the 750 but still the same, run about 100 yards and die,
    towed it over to the trailer,brought it home, took the spark plugs out and it seemed like there was a little water in the pto cylinder,
    I took all the spark plugs out and turned it over and it seemed like a little water sprayed out, I had the gas turned off, but on about every 10 rpm's it seemed like old faitfull in the pto cylinder, It would mist a little every now and then,
    I smelled like gas, but I had the fuel valve off,
    ??

    any ideas??


  2. #2
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    did you check spark?

    what did your plugs look like? any water in the boat?

  3. #3
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    there was about 1-2 inches in the bottom of the hull, not too much,
    I don't know how water could have gotten in the rear cylinder? I still have good compression on all 3,

  4. #4
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    unless when I pulled it out the front water box, water ran back into the engine?
    since it died out in the water, I couldnt blow out the waterbox when I cranked it on the trailer,

  5. #5
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    i was thinking maybe your carbs sucked some in.. but i would think all three cyl would have water..

    it could just be gas from not sparking good..

    whats the spark look like? nice and blue?

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    get it running and blow it out and fog it for now

  7. #7
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19


    even if its just gas better be safe then sorry..

  8. #8
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    another thought was that one time my wife was right buy the pier, and I threw her a rope and pulled her in backward, could water have gone in the exhaust pipe backwards?

  9. #9
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I still am wondering, why it was acting up to begin with? It usually runs solid?

  10. #10
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    do you have a water shut off valve installed? i used mine today matter of fact and got towed 2 miles to shore at 25 mph works great. sounds like you could use one.

    are you using the watcon water routing?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Todays Ride with the new and improved Pro 785
    By skigolfnut in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-04-2012, 08:49 AM
  2. Pro 785 running very strange... please help
    By jcjw1998 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-07-2010, 07:38 AM
  3. Bought a PRO 785 off craigslist today.
    By Tony in forum Polaris Open Discussion
    Replies: 46
    Last Post: 12-26-2009, 08:03 PM
  4. pro 785 questions \ help needed
    By [email protected] in forum Polaris PWC Performance
    Replies: 14
    Last Post: 09-13-2006, 08:40 PM
  5. Pro 785 head question
    By absentx in forum Polaris PWC Performance
    Replies: 8
    Last Post: 09-05-2006, 04:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •