Results 1 to 9 of 9
  1. #1
    xpfreak's Avatar
    Join Date
    Jun 2009
    Location
    phenix city alabama
    Posts
    28

    what should my speed be?

    i have a 2000 xpl and im only getting like 49 on gps. where should i be?


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    What RPM?

    That is like 10mph too slow for a stock XPL.

  3. #3
    xpfreak's Avatar
    Join Date
    Jun 2009
    Location
    phenix city alabama
    Posts
    28
    only like 6400 -6300 changes alot

  4. #4
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    you should be turning 6900. sounds like your RAVES are not opening. but it sounds like thats not your only problem as fixing the RAVES would not give 10mph. clean your RAVES to get your rpms back up and see where you ae from there.

  5. #5
    xpfreak's Avatar
    Join Date
    Jun 2009
    Location
    phenix city alabama
    Posts
    28
    okay im no where close to 6900 thank you!

  6. #6
    xpfreak's Avatar
    Join Date
    Jun 2009
    Location
    phenix city alabama
    Posts
    28
    what speed should i be looking for?

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Get your RPM to where it should be and then see where you are.

    Not to dispute the king but if you are running the right oil and the boat has not been sitting up for a number of years the RAVEs are not likely to be stuck from being dirty.

    It is possible the RAVE solonoid is not working. It is right above the engine where the two little lines lead off the valves. If you pull the electrical plug to it and then take a speed run and your RPM does not go down than the RAVEs are not working. It would remain to be seen if the solonoid is working, however. The next step is to take the caps off. If the valves will move and if the WOT RPM comes up (though it will suck down low) to where it should be (say 6850+ ish) then the RAVEs are not stuck and it is either the solonoid of the check valve in the pressure supply line is bad, or the pressure supply line has a hole in it.

  8. #8
    xpfreak's Avatar
    Join Date
    Jun 2009
    Location
    phenix city alabama
    Posts
    28
    i sent you a pm

  9. #9
    even something as simple as a rave coil spring will drop rpm's down from hi 6's to mid 6's and it will drop mph a good 7.
    those last 500 rpm's make a huge difference

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Model XP - 951 - What should my RPM be?
    By SinWolf in forum 2-Stroke Performance
    Replies: 12
    Last Post: 05-04-2016, 07:42 PM
  2. What should idle speed be? Can it be lowered ?
    By Avi8tor in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-22-2012, 10:10 AM
  3. What should my power an speed be??
    By Trond in forum 4-Tec Performance
    Replies: 20
    Last Post: 12-06-2007, 10:17 AM
  4. What should my rpm be??
    By DeeGee in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-15-2006, 04:35 PM
  5. What should the speed be of a "stock" 2005 RXT?
    By BrAinZ in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-05-2006, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •