Results 1 to 2 of 2
  1. #1

    95 800 xp parts question

    is there any way to test the ecm before going out and buying a new one?


  2. #2
    yankee817299's Avatar
    Join Date
    Jul 2008
    Location
    Arlington, TX.
    Posts
    90
    Hi Tony,

    Welcome to the forum. Just post a reply to your first post. This will enable other riders who might be experiencing the same problems will have all the replies in one thread.

    It sounds like a fuel delivery problem, probably the carbs gummed up from sitting idle for a couple of years. Might try cleaning the carbs and getting rid of the gray fuel lines, as stated in the original thread. Either way, there is enough knowledge on this forum to walk you through any repairs or problems that may come up. Keep your chin up and good luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. still having problems with 95 800 xp
    By TonyT in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-21-2010, 07:14 PM
  2. having problems keeping my 95 800 xp running
    By TonyT in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-16-2010, 07:46 PM
  3. 95 800 xp has ratle when in idle??
    By TonyT in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-09-2010, 05:28 PM
  4. 95 xp 800 ELECTRICAL part
    By tack in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-29-2008, 09:41 PM
  5. 94 xp 650 with unknown performance parts questions
    By johnson7454 in forum 2-Stroke Performance
    Replies: 17
    Last Post: 04-21-2008, 11:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •