Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2009
    Location
    winston salem, nc
    Posts
    104

    What's Up?? HELP!!!

    This is the second nozzle i broke yesterday when trying to reassemble my 96 slt780. both times as the bolts started to tighten up the water pick up receptacle on the nozzle broke off. the 1st time i thought i had gotten the hose in a bind but the second time it was straight. i used a new o-ring and greased it all up good. i even cleaned out the inside the pick up where the hose slides in with steel wool until it was smooth and shiny. the only thing i can think of is the wedge is too thin. i had 2 wedges and i used the thinner one b/c i wanted to save the thicker one for the sltx. could it be possible that the slt 780 requires the thicker one or there is not enough clearance between the nozzle and the water pick up hose. has anyone ever done this??? does anyone have a nozzle they want to sell?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0743.jpg 
Views:	31 
Size:	83.5 KB 
ID:	192321  


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Your water tube is too long. You can grind down where it enters the hull too make it shorter.

  3. #3

    Join Date
    Apr 2009
    Location
    winston salem, nc
    Posts
    104
    thanks beer. that would explain it. wonder why it worked before?? i'll post a wtb in the classifieds.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Some water tubes are slightly longer than the normal length.

    You may need to trim the length of the tube, or install one of the shorter tubes.

    Question for guys running 6* wedge

    Which water tube are you using ? I have a...


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What's up with sea doo help
    By primorxp in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 01-07-2010, 09:19 PM
  2. What`s up with Mark Underwood
    By Big Red Monster in forum 4-Tec Performance
    Replies: 62
    Last Post: 07-28-2006, 10:59 PM
  3. What`s up with the forum???
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 05-22-2006, 08:46 PM
  4. Guys with UMI set ups... Help me out. Please.
    By Water4fire in forum 4-Tec Performance
    Replies: 31
    Last Post: 05-06-2006, 02:17 PM
  5. Novi 48's Carb set up -- (help)
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 02-13-2006, 10:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •