Results 1 to 4 of 4
  1. #1
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1

    RXP MPEM questions

    im getting another MPEM for my 04 rxp cause mine to a dump. do i plug in the new one and run it or do i need to connect the ski to BUDS?

    thanks
    mannie


  2. #2

    bud

    you need a bud

  3. #3

    Join Date
    May 2005
    Location
    Louisville KY.
    Posts
    156
    You need to have the key programed to it, and the TPS set. So yes you need to have it hooked to BUDS.

  4. #4
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    cool, thanks for the info.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP mpem question
    By Bosch Man in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-21-2012, 01:56 PM
  2. RXP spray question
    By davidl13 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-06-2006, 09:52 PM
  3. Newbie RXP owner questions
    By mickey78 in forum Sea Doo Open Discussion
    Replies: 19
    Last Post: 07-14-2005, 11:49 PM
  4. RXP Speedo Questions
    By tchies in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-21-2005, 06:38 PM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •