Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    One last impeller torque ?

    Ok im installing my impeller and i asked in my other thread (which i cannot find) about torque specs for the allan bolt. The manual says 59ft lbs. Others in here mentioned that they went to 90 i believe....

    Im using a vice to hold the impeller tool and a floor jack handle to slip over the allan wrench. Now, when doing this, there is obviously no way to measure the torque except to know that a 3-4ft long jack handle will go way beyond 59ft lbs even with just moderate feel, especially if you grab it by the back end for max leverage...

    my question is, if i just go by feel and use only moderate strength with the jack handle, are there any possible side effects (against the impeller or pump assembly) to unkowingly torquing it down to 70-100lbs etc???

    Meanwhile, i used antiseize lube on the threads to let it achieve a smooth, even torque.


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    I always thought the prop torque was 92ftlbs at least on a RXP or RXPX.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I always use Blue locktite, and with a 1/2" breaker bar I make it "good and tight" with moderate force.

    Many prop changes, and never a problem

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by psycho rxp View Post
    I always use Blue locktite, and with a 1/2" breaker bar I make it "good and tight" with moderate force.

    Many prop changes, and never a problem
    Hey, I thought you broke shaft at the Hydrodrags a couple years ago.

  5. #5
    According to the shop manual its only 59ft lbs. I guess thats about right since there's nothing going on to make it unscrew itself

    Hey psycho.....how long do u think your 1/2in breaker bar is?

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Oh well, mine says 92ftlbs 08-09 manual. Torque to whatever. But I have seen what a loose impeller can do to a engine its not pretty.

  7. #7

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Quote Originally Posted by jp1300r View Post
    Oh well, mine says 92ftlbs 08-09 manual. Torque to whatever. But I have seen what a loose impeller can do to a engine its not pretty.
    Thats what I was told. I always just goto 100. Easier to read. No loctite. Just antiseez.

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by blkturbo! View Post
    According to the shop manual its only 59ft lbs. I guess thats about right since there's nothing going on to make it unscrew itself

    Hey psycho.....how long do u think your 1/2in breaker bar is?

    Bout 18"

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by jp1300r View Post
    Hey, I thought you broke shaft at the Hydrodrags a couple years ago.

    I had the nose cone walk up the shaft, and limited me to 7800rpms, no matter what I did.

    I did however break my handle bars on the throttle side that day...lol

  10. #10
    Tighten that sum biotch till the pump shaft breaks, then back it off a half a click. Always works for me.

    Mark

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Tonight: Choke shaft removal stuck on one last clip
    By chuckcanavi in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 09-03-2011, 06:43 PM
  2. Prop removal question one last time
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 03-20-2010, 11:09 AM
  3. Replies: 4
    Last Post: 08-25-2009, 07:22 PM
  4. one last question
    By dridog1958 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-27-2009, 07:33 PM
  5. Which one of these torque wrenches do I need?
    By grantuk in forum 4-Tec Performance
    Replies: 8
    Last Post: 02-03-2009, 09:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •