Results 1 to 8 of 8
  1. #1
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4

    Lightened my hull... lost speed!

    Gas mileage went up, though
    Attached Files Attached Files
    Last edited by 05Limited; 09-27-2006 at 04:12 PM.


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

  3. #3
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    That thing is kinda cool actually

  4. #4
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    looks like a dog humping someones legg

  5. #5
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    959
    +1
    2
    That is sooooo cool....where can I get one?

  6. #6
    PiMPNXP's Avatar
    Join Date
    Dec 2005
    Location
    So Cal.....
    Posts
    612
    Just dont stop or you will be at the bottom of the lake.....

  7. #7
    Dont judge me...
    Join Date
    Jul 2006
    Location
    FLORIDA
    Posts
    610
    looks like to much work....

  8. #8
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    there on ebay

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installed RIVA Thru-Hull & Lost Speed?
    By CLASSIC MUSCLE in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-14-2015, 07:21 PM
  2. Trying to find my lost speed
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 47
    Last Post: 09-27-2012, 07:14 PM
  3. My RXP Mod & Speed History
    By Jarrett in forum 4-Tec Performance
    Replies: 15
    Last Post: 06-02-2006, 12:18 PM
  4. What should I do to my hull? Pics on the way!
    By ccassone in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 03-15-2006, 07:00 PM
  5. Found cause of lost speed
    By Sundance in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-10-2005, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •