Results 1 to 9 of 9
  1. #1

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19

    Pics of removed jet pump/and help

    Welp the teardown of my jet pump is completed, took about 15mins haha. I was a bit concerned about the 4 long bolts, but they were loose. Now i wish I didnt waste a day/50 bucks taking it to the dealership. I do have one issue, the bolt that holds the steering cable to the steering nozzle is frozen. Theres no bottom nut just the threads coming out. I cranked on it but i think it'll break, so I'll just leave it on for now. I used PB and I even used a quick burst of heat (mapp gas on the SS itself no less )but it's stuck right in the aluminum part. I think i could drill it out and get a new bolt, but it might just be less of a headache to find a used one and a new bolt. So I just removed the 4 bolts and tied the nozzle up to the side.

    So here are some pictures, I talked to Sharps Marine and I'm pretty pumped they sound so great. If you can't tell, my stator is SHOT! I'll be getting a SS one from sharps. Now about my impeller, does it look beat? I'd like to get a nice used one since the edges bounced around and sliced it up good.(It has maybe 5 hours of use, so I'm ticked) My wear ring looks good (i dont have a pic, because I have yet to get it off, didnt pop off when i 2x4'd it just the stator and driveshaft/impeller)

    Drive shaft looks good, splines look good, minus the bumper on the end is broke, i'll order some new ones. The cone was FULL of water and everything looks pretty bad. STUPID SALT WATER! I havent pulled the stator apart yet, but I'll get new bearings etc for the new one (the stub shaft should be fine right?) My question is why does mine look different then K's teardown? I think the stub shaft is just pulled through more? I'll check more when I get home.

    I'm excited and it was so RIDICULOUSLY EASY! I will have sharps pack the stator properly(he said he'd do that for me) and possibly install the impeller onto the shaft. (although I have a removal tool just in case)

    I have to finish my deck this weekend, but by next weekend I should be riding again! woot woot!


  2. #2

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19
    forgot the pics...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1.jpg 
Views:	43 
Size:	146.9 KB 
ID:	192745   Click image for larger version. 

Name:	2.jpg 
Views:	44 
Size:	60.2 KB 
ID:	192746   Click image for larger version. 

Name:	3.jpg 
Views:	40 
Size:	164.5 KB 
ID:	192747   Click image for larger version. 

Name:	4.jpg 
Views:	42 
Size:	64.2 KB 
ID:	192748  

  3. #3

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19
    sliced up impeller...but check the part number?! is this the correct impeller even!?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	6.jpg 
Views:	63 
Size:	162.1 KB 
ID:	192749  

  4. #4
    Cliffy's Avatar
    Join Date
    Oct 2009
    Location
    UK,
    Posts
    566
    Ive just had my 780SLT have the same thing, my stator was refurbed, only had 1 minor chip, my bearing had also gone they fell out lol, and the cone was soak but no major damage etc

    My impeller had damage to the leading edges etc, im guessing ur getting the wear ring done to??

    The stub shaft should be fine, make sure u get the end piece back on the shaft first, k447 advise of a part number from abonther ski if u struggle for one

    The first shot of ur impeller didnt look to bad but the second one looks like a big chunck is missing, need some more pic's of that

    I'd say ur shaft dropped out more than k447 because of the bearing failure nothing to worry about though dude

  5. #5

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19
    no, no wear ring, I have to inspect it a bit more, but it looks good and is only about 5hours old. on the stub shaft what end piece are you referring to? the one that'll take a cresent wrench? i'll get a few more of the impeller, its almost sheared off, and there's a good amount of metal slices hangin there.

    what impeller should I get? like i said, the new one that is now broke is part number 5131366 which i think was for the genesis

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by absolutesltx View Post
    ...what impeller should I get?

    like i said, the new one that is now broke is part number 5131366 which i think was for the genesis
    5131366 is the correct impeller for a 1997 SLTX

    Do inspect the wear ring closely. That impeller was banging around inside the wear ring.

    I would try using the SBT impeller refurb service. For $25+shipping, you will get back a like new impeller.

    Check your stub shaft carefully, If it is bent near the threaded end, or has damage where the bearings ride, it may need replacement.

    Also check the spacer that sits between the bearings. If it has been worn or damaged at the ends, it cannot be used. The length of the spacer is a precision fit.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris impellerchart (1997-1992).jpeg 
Views:	35 
Size:	160.0 KB 
ID:	192857   Click image for larger version. 

Name:	Polaris impellerchart (2002-1998).jpg 
Views:	34 
Size:	64.2 KB 
ID:	192858  

  7. #7

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19
    welp, the reason my stub shaft looked different was because it had snapped off, look at the pic of the end of the impeller, the threaded end of the shaft is still in it

    so I'll pop it in a vice and order a new stub shaft as well

    also theres no way i can get those bearings out to get to that ss spacer and the other spacers out, so I'll order those too.

    I'll check the wear ring tomorrow, figure SS 6 vane, with a SS impeller, mind as well go with the SS wear ring too sheesh

    costing me too much already, but hope she'll fly afterwards

    To buy:

    stub shaft
    rebuild kit (bearings/orings)
    both spacers
    sbt impeller swap
    6 vane stator
    (possibly) ss wear ring

    anything else?

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by absolutesltx View Post
    ...anything else?
    Rubber drive shaft end bumpers good?

    I think SBT sells the stator rebuild kit with bearings and seals, if the stator you buy doesn't come with good seals and bearings.

  9. #9

    Join Date
    May 2010
    Location
    Rochester NY
    Posts
    19
    nope, thanks k447, i ordered those from partsland too, forgot to post up. I found the rebuild kit at sbt (59.95) or something along those lines.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jet pump and adapter leg HELP
    By highboostrxt in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-21-2015, 09:41 PM
  2. Help Removing Jet Pump
    By garland in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-25-2012, 03:11 PM
  3. Pics of old fuel pump and filters
    By skigolfnut in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-24-2012, 12:08 PM
  4. Running rough after jet pump and carb. removal
    By sebas54 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 05-12-2010, 07:03 PM
  5. Anyone have a pic of RXP jet pump support ?
    By DaveC in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-16-2008, 05:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •