Results 1 to 9 of 9

Thread: Please help

  1. #1

    Please help

    I have a Sea Doo GTX 4stroke 06 here in Iceland.
    There arent many jet skis in so there is no one that is good repearing them.

    I have been looking at it myself (i have a shop manual) and took it to a ski-doo dealer and it seams the MPEM is done.

    Is there anybody in the US that can fix them ????

    If i buy a new one from usa it will cost me about 1950$ when i get it in my hands

    Please help.


  2. #2
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    Search for a used one, will be between 100$~200$

  3. #3
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    I have one for 06.

    But, before you change it, what is actually wrong with it, as sometimes it is good to have a second opinion...

  4. #4
    Quote Originally Posted by Richieb View Post
    I have one for 06.

    But, before you change it, what is actually wrong with it, as sometimes it is good to have a second opinion...
    When i put the dess key in i dont get the display,no beep, cant start or do anything. The only thing it does is the fuel pump starts and some valve one the side of the engine oil cap clicks.(i have new battery all fuses,connections and ground is good)

  5. #5
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001

    A to B cable connector.

    Does the VTS work?

    Can you check the 4 pin connector that is usually at the front of the inlet manifold closest to the front.

    It will be grey in color, and square sectioned. You will find one end is the engine cable, and the other goes to the rest of the ski. 2 of the wires are white, with a red strip and one with black stripe on it.

    This is the communication link to the B Cable, MPEM, and the DESS lines. The signal drives the logic in the MPEM.

    Sometimes the red seal goes missing, and water will get in there and ruin comms.

    Check this first, and get back to here with reply.
    Last edited by Richieb; 06-09-2010 at 11:36 PM. Reason: Mis-triped!!

  6. #6
    Quote Originally Posted by Richieb View Post
    Does the VTS work?

    Can you check the 4 pin connector that is usually at the front of the inlet manifold closest to the front.

    It will be grey in color, and square sectioned. You will find one end is the engine cable, and the other goes to the rest of the ski. 2 of the wires are white, with a red strip and one with black stripe on it.

    This is the communication link to the B Cable, MPEM, and the DESS lines. The signal drives the logic in the MPEM.

    Sometimes the red seal goes missing, and water will get in there and ruin comms.

    Check this first, and get back to here with reply.

    I will check this out and let you know.

    Is it possible to buy your mpem if mine is done ?

  7. #7
    Quote Originally Posted by Richieb View Post
    Does the VTS work?

    Can you check the 4 pin connector that is usually at the front of the inlet manifold closest to the front.

    It will be grey in color, and square sectioned. You will find one end is the engine cable, and the other goes to the rest of the ski. 2 of the wires are white, with a red strip and one with black stripe on it.

    This is the communication link to the B Cable, MPEM, and the DESS lines. The signal drives the logic in the MPEM.

    Sometimes the red seal goes missing, and water will get in there and ruin comms.

    Check this first, and get back to here with reply.

    I checked this nothing happened i have done everything nothing works.

    My mpem is done, pm me info if you want to sell yours.

  8. #8
    Sounds more like the ECM is faulty.

  9. #9
    Check your AMP connections on the MPEM for water or corrosion and the ECM connections.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM
  2. 4-Seater jetski with Mercury Jet Propulsion... please help
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-19-2005, 02:18 PM
  3. Please Help!!!!!!!!
    By RXP215 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2005, 10:09 AM
  4. CHEWED UP SOME ROPE TODAY PLEASE HELP
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-07-2005, 02:14 PM
  5. PLEASE HELP MUSIC DOWNLOADING
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-05-2005, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •