Results 1 to 4 of 4
  1. #1

    2002 GTX, 4-Tec Limited

    This 5 amp fuse that keeps blowing is located on the starter relay, I think. There is a relay bolted on next to the main fuse box that has heavy cabling coming out of it going to the starter. This relay box has (2) fuses plugged on to it. (1) 20 amp and (1) 5 amp.

    The unit has a new battery in it. Unit starts and runs fine however, I am suspicious of the charging system working. I started probing around and the first fuse I puled was the above mentioned 5 amp. It was blown. I check the other 20 amp fuse was fine. Replaced the 5 amp fuse, install the lanyard, hit the start button, blew the 5 amp fuse instantly but yet still started.

    What is likely causing this fuse to blow. My manual dose not disclose this fuse?

    Rick


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    I thought both of those were 20a

  3. #3
    MRBTD

    I just did get a diagram from a dealer. The print shows them both to be a 30 amp. One of them is in between the rectifier and the battery post and the other is in between the battery and the main fuse box. Dose this sound right to you.

    Rick

  4. #4
    MRBTD

    I just did get a diagram from a dealer. The print shows them both to be a 30 amp. One of them is in between the rectifier and the battery post and the other is in between the battery and the main fuse box. Dose this sound right to you.

    Rick

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 04-03-2016, 10:03 AM
  2. 04 Seadoo GTX 4-TEC limited.. good deal ?
    By Oldskool1965 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 02-15-2009, 03:36 PM
  3. WTB: 2002 GTX 4-Tec Drive Shaft
    By thompsdw in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-24-2008, 08:09 PM
  4. 2002 GTX 4-tec in NC
    By NCRXP in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-18-2008, 08:53 AM
  5. 2002 GTX 4-tec turns over but won't start.
    By mc_4-tec in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-09-2007, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •