Results 1 to 9 of 9
  1. #1
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1

    150 psi too much?

    i just did a compression test in all 3 of my cylinders and they are at 150psi. i read somewhere here that that may be too much? if so how do i correct this? the camshaft gear's line sit perfectly flat with the head (1503 lines)


  2. #2

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    150psi is good

  3. #3
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Excellent numbers, and superb balance across all three.

    I would not complain.

  4. #4
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    wow perfect compression. ussually you will see from 135psi to 145 psi in the 4-tecs...

  5. #5
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    04-05 cams Must be 145PSI
    06+ cams Must be 140PSI
    ROtax b kit cam Must be 135 PSI

  6. #6
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    thanks for the info guys, engine runs great except for a crazy boost leak that i can't seem to trace. i was running 13 psi at 8100 with stock ecu and now with rr ecu i'm only doing 12psi at 8200. is this normal with the ecu or should i be getting the same numbers regardless? i pressurised the system at 30 psi and found only trickle leaks

  7. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by masta2000 View Post
    thanks for the info guys, engine runs great except for a crazy boost leak that i can't seem to trace. i was running 13 psi at 8100 with stock ecu and now with rr ecu i'm only doing 12psi at 8200. is this normal with the ecu or should i be getting the same numbers regardless? i pressurised the system at 30 psi and found only trickle leaks
    I'm thinking bad boost gauge.

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    The stock plastic manifold normally would explode, or leak over 25psi

  9. #9
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    could it really be a bad boost gauge? im running 79 at 8400rpm, is this what a rude1 is supposed to do?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Milling 63m head. How much equals 150 psi??
    By MGannaway in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-05-2013, 08:44 AM
  2. 180 PSI too much?
    By codemanrose in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 10-21-2008, 10:40 PM
  3. 185 psi too much on each cylinder for pump gas?
    By Joe Stang in forum 2-Stroke Performance
    Replies: 10
    Last Post: 09-18-2008, 04:26 PM
  4. this vid is too much...
    By yamaslut in forum Open Discussion
    Replies: 12
    Last Post: 09-21-2006, 06:15 PM
  5. This guy watched too much TV!
    By spdracr in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-17-2006, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •