Results 1 to 7 of 7
  1. #1
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74

    Lightbulb Polaris Virage Gauge Cluster Question

    I am having issues with my gauge cluster on my Virage not working. I just got the jet ski so I dont know anything about it. Should the display on it work without starting it? I checked the 1/4 amp fuse in the electrical box and still nothing. Any help woul dbe appreciated.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    If you crank it for a second will the mfd come alive?

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    If not, remove the cluster and verify 12 volts and ground to the connections. Did you use an ohm meter on the fuse to verify it's good?

  4. #4
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    Im new to the jet ski world so what do you mean mfd? I cranked it up before I tore the motor apart and nothing came on. I would assume as soon as you fire it up it would turn on correct? I shouldnt have to hit any buttons to turn it on?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by YoCoLifSavr View Post
    I am having issues with my gauge cluster on my Virage not working. I just got the jet ski so I don't know anything about it.

    Should the display on it work without starting it?

    I checked the 1/4 amp fuse in the electrical box and still nothing. Any help would be appreciated.
    This a carburetor two cylinder engine - correct?
    2001 Virage - correct?

    How did you check the fuse for the MFI display?
    Tip: The large display on the Virage is called an MFI, but many members here use the term MFD to refer to any Polaris digital display, regardless of type.
    Do you have a multi-meter tester?

    Check for voltage at the connector behind the MFI.
    Unplug the connector, and insert one meter probe into the Black wire socket (Ground), and the other meter probe into the Red/Purple (Red/White on some models) which is 12 volt power.

    You should measure full battery voltage (about 12.5 volts). If not, recheck the 1/4 Amp fuse in the electrical box.

    Next move the probe from the Red/Purple to the Yellow wire in the connector. Again it should show battery voltage.

  6. #6
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    K447 - Yes it is a carb'd 700 2 cyl 2001 Virage. It should have power to it at all times correct? While im waiting for my piston to come in im trying to troubleshoot the gauge problem. I will check voltage with the multimeter. I pulled the fuse out to check to see if it was burnt through. That is the only way I checked it.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by YoCoLifSavr View Post
    K447 - Yes it is a carb'd 700 2 cyl 2001 Virage.

    It should have power to it at all times correct?

    ...I will check voltage with the multimeter.

    I pulled the fuse out to check to see if it was burnt through. That is the only way I checked it.
    Check the fuse with your ohm-meter. Should read zero ohms.

    Only replace with another 1/4 Amp fuse.

    Display should have power at all times, and the clock should be visible all the time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pop off/thermostat 2000 polaris virage tx 1200 question
    By timbo2 in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 08-06-2016, 07:46 AM
  2. 06 to 09 Gauge cluster question
    By mlgarner in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-05-2016, 03:30 PM
  3. SOLD POLARIS Virage Gauge / Instrument Cluster
    By Marineking in forum Polaris Classifieds
    Replies: 6
    Last Post: 06-20-2012, 07:37 AM
  4. 2002 Polaris Virage - EMM computer question
    By kkn0621 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-17-2011, 12:09 AM
  5. '07+ Digital Gauge Cluster Questions...
    By duramaxxed in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 08-05-2008, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •