Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2007
    Location
    Louisburg, NC
    Posts
    88

    leaking rave valves and loss of power

    ok so my rave valves r leaking pretty bad and my ski is lacking acceleration, it goes but no like it is suppost to. i know im running really rich fuel so i know the plugs are fouled....i took it up to the lake and when i got there i noticed the oil pump stopped working but i wanted to ride so i said scew it and got the ratio rite out and premixed the gas well after about 10 mins i noticed alot of excessive smoke and i took a look and the oil pump was working ...i guess i didnt get all the bubbles out of the main oil line when i put the engine back in. i took it back out the day after that and topped off the gas tank with strait gas so it was diluted alot and cleaned the spark plugs but it still lacks take off and i noticed alot of leakage around the rave valves and i know they control exhaust back pressure so could this have something to do with it? i cleaned the recently and replaced the gaskets also.....would new bellows, o-rings, and gaskets stop this leak?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	digitial camera 023.jpg 
Views:	88 
Size:	120.6 KB 
ID:	193205   Click image for larger version. 

Name:	digitial camera 022.jpg 
Views:	108 
Size:	88.0 KB 
ID:	193206  


  2. #2
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Anyone else get a headache from reading this???




    I would flush your fuel, take the raves out and give them a good cleaning with new gaskets and o-rings and then see what it does.

  3. #3
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    Lol Joe....


    I only read title, I have short attention span


    Looks like the green boot inside rave maybe torn or your gaskets shot where it bolts on...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 Seadoo RXPX 255 Low RPM and Loss of Power
    By Sassafras in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2016, 07:52 PM
  2. 2012 RXP X rpm jumping and loss of power
    By Ljpviper in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-03-2013, 08:44 AM
  3. just bought a 550 and there is salt water build up in the head??? and loss of power..
    By dirtydave916 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-21-2011, 11:30 PM
  4. overheating and loss of power problems
    By yama-doo in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-17-2010, 05:08 PM
  5. Overheating and loss of power on 2001 Virage TX
    By bruce0429 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-14-2009, 02:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •