Results 1 to 2 of 2
  1. #1

    Join Date
    Mar 2010
    Shoreview, MN

    900 zxi not full power

    so i just had my 96 900 zxi rebuilt and i don't think it's running quite right. the carbs are rich right now so i don't blow up the new motor but it doesn't always rev out. it will sometimes just rev to 6000 rpms and go like 30-35mph and randomly it decides it will run at 7100 all of a sudden and do like 42mph. shouldnt it be faster? everything is stock and it has a new stock impeller.

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    If it's too rich, it won't run full speed. Since you're breaking it in, don't worry about it right now. After you get the rings seated, tune it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 ZXI 900 No Spark
    By Speedy4 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 11-27-2007, 06:01 AM
  2. What to look for in a 1996 Kawasaki ZXi 900
    By jaminjarmin in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-07-2007, 10:02 AM
  3. 96 zxi 900
    By cardudenc in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-04-2007, 10:42 PM
  4. 900 zxi stearing cable
    By grifter in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 05-19-2007, 10:56 AM
  5. 900 zxi help
    By axgrider73 in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 03-20-2007, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts