Results 1 to 7 of 7
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    2002 TXI No MFD wake up

    Hello,
    I had my ski's out during memorial day. (Thanks to K447 and Bernie) they ran great. Tried to start The TXI today and MFD would not wake up with cranking. (Key was in) I can press the display button and it wakes up that way.
    Ski does not start, only turn over.
    Any Suggestions? Thanks.
    Last edited by dalepatter; 06-25-2010 at 04:52 PM.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    It sounds like the system is not delivering voltage during cranking.
    Will it start if you hold the bilge button down?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,579
    +1
    1,272

    2002 TXI No MFD wake up

    Check fuses

    Unplug tps and try starting


    Sent from my iPhone using Tapatalk

  4. #4

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Checked a few things.
    Bilge works when pressed, no key necessary. MFD will still not wake up when trying to start and Bilge button is pressed. Bilge pump does power on.
    I disconnected the TPS and tried it, still nothing at first. then on the third or fourth time cranking witout the TPS plugged in the MFD woke up. Tried about another 10 times and would not wake up again. Could the Kill switch be bad?
    The fuses to check? The circuit breakers are in the down position.
    I be looking at this a little more tonight. I find that if I work on it for short durations I don't get as frustrated.
    Thanks...

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,579
    +1
    1,272
    It sounds like the EMM has a problem, or something feeding into the EMM is wrong.

    When the EMM first senses the engine cranking (via the stator AC voltage into the EMM's DC power section, and the CPS signal from the top of the flywheel) it wakes up and immediately sends a wake-up signal to the MFI via the Yellow RPM wire.

    Since your MFI is not waking up when you crank, that suggests the EMM doesn't think the engine is rotating.

    Check the ohms on the CPS sensor.

    It is possible that the lanyard switch is faulty, but right now I am thinking it is something else.

    You can bypass the LR-503-1 Start-Stop module (4010724)

    Try this test;
    Help. Virage I Not Running

  6. #6

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    MFD wakes up now, I did not do anything. I have zero fuel pressure again. And the Virage I still does not start. This is it...I AM DONE. Thanks for the effort.
    I am selling both of these ski's (2003 TXI 63 hours and 2002 Virage I 90 Hours) and a double aluminum trailer for $3400. PM if interested. Located SE Michigan.

  7. #7

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    Pictures of skis for Sale...Maybe someone else will have better Luck.

    The Virage I tries to start will sometimes start with throttle position sensor unplugged. If it does start it backfires and runs rough and will only do so a few seconds.
    TXI no fuel pressure.
    Check my posts about these ski's.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	polaris1.jpg 
Views:	29 
Size:	8.4 KB 
ID:	194939   Click image for larger version. 

Name:	polaris2.jpg 
Views:	26 
Size:	8.5 KB 
ID:	194940  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MFD flashing HOT/OIL by waking up, registers NO oil level
    By loonatik in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-01-2014, 07:39 PM
  2. Waking up mfd
    By OLDJETSKIMAN in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-01-2010, 09:13 PM
  3. 2002 genesis txi, has to warm up for 5 min
    By kc44408 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-04-2009, 08:42 PM
  4. Round MFD will not wake up!!
    By 1stpolaris in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-28-2009, 10:37 AM
  5. Wake Up America!!! No Amnesty!!!
    By Wetracer in forum Open Discussion
    Replies: 1
    Last Post: 06-07-2007, 10:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •