Results 1 to 6 of 6
  1. #1

    Smile # fx_shos need working on

    I live in south louisiana I need a qualified mechanic that knows what they are doing. I have a fx-sho thats not running right and the last idiot I brought it to just put it on the computer and said nothing was wrong with it. I have three fx shos and this is the only one running bad. If you have an idea or a shop close to new orleans or within 100 miles of it gimme a shout 5044153172 or give me an email with your number and ill contact you.


  2. #2
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by lafitteboy View Post
    I live in south louisiana I need a qualified mechanic that knows what they are doing. I have a fx-sho thats not running right and the last idiot I brought it to just put it on the computer and said nothing was wrong with it. I have three fx shos and this is the only one running bad. If you have an idea or a shop close to new orleans or within 100 miles of it gimme a shout 5044153172 or give me an email with your number and ill contact you.

    Good grief, hope it gets worked out. There are a lot of little silly things that could cause small issues that the computer would never see.

    Could even give a detailed description here and we might be able to tell what it is. Between all of use we have seen just about everything.

  3. #3
    ok I have a stage one riva kit installed. It did the same thing before the kit so we ruled the kit out. when I first hit the gas it gets going and as I hit 6900 the engine seems to bog down then it eventually catches up. I have two others and neither of them do it. I switched fuel injectors from one of the other ones to this one and it still did it. If the water is a little colder it doesnt do it as bad or if I take the seat off its not as bad. top end its running pretty good im beating the othere two so im thinking thats ok but as soon as i start playing around it starts to lag a little when i hit the throttle and at 6900 to 7000 rpm every time my rpm almost drops off but if I pull the trottle slowly it will go thru the rpm without lagging. Its only when I gun it. I also changed the spark plugs. It doesnt miss or run funny at idle or top end.

  4. #4
    vomitspot's Avatar
    Join Date
    Apr 2006
    Location
    mobile alabama
    Posts
    722
    is it cavitating out of the hole and hitting the rev limiter? 7000rpm maybe the oem tac cant keep up?

  5. #5
    Yes thaqts wats crazy when i gun it out the hole the bike usualy hit the limiter and gets going ok its only when im cruiseing at about 5500 and i gun it it shoots to abo 6800 then very slowly trickles up to abo 75 to 7600. Its almost as if its either flooding really bad or leaning really bad. I thot mabe injectors but i swaped from another bike and still did the same. Did a compression test and i had good compression. emptied out tank with a pump and put fresh gas. Changed the spark plugs. I pulled a tube it had really good torque.

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    I'm in Houston and would be glad to take a look at them

    I drive to Beaumont area a couple times a month, and would be available to meet you for a hand-off

    send me a pm if interested

    Rich

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP!!! Need someone who works on MFD
    By johnhansen3 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-10-2013, 07:55 PM
  2. need work on crank
    By rich.allen in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 11-18-2012, 09:32 AM
  3. 04 RXP (155 hours) Need Help On ECU not working correctly.
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-21-2010, 01:03 AM
  4. 04 RXP (155 hours) Need Help On ECU not working correctly.
    By davidrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-21-2010, 01:02 AM
  5. Replies: 1
    Last Post: 06-30-2008, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •