Results 1 to 7 of 7

Thread: 2001 Virage TXI

  1. #1

    Join Date
    Jun 2010
    Location
    Hilton Head
    Posts
    10

    2001 Virage TXI

    i recently purchased two 01 Virages TXI . I was told they were running last year last year. No batteries at time of time of purchase. but they would turn over. I found one needs at new computer board. The other started up ran great for 10 minutes hit 45 just while getting use to it. I picked up a passenger and went back out and it started to bog down didnt stall,, it kept an idle and putted around enough to get to shore. I went back out it ran fine. Then it did the same thing the machine will stay running but when it gets the throttle it just bogs down. Help me out . Thanks New gas, battery and oil??


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Welcome

    You are going to need to do some diagnostics.

    How did you determine the non-running machine needs a new EMM?

    When the other one runs poorly, is there a red lamp or warning message on the display?

    Try swapping the TPS (Throttle Position Sensor) from the non-running engine to the problem engine. See if it runs better, or at least differently.

    Make sure the correct spark plugs are installed, and are fresh. NGK PZFR6H only - no substitutes.

    Polaris Ficht Fuel Injected Engines

  3. #3

    Join Date
    Jun 2010
    Location
    Hilton Head
    Posts
    10
    The non running machine I took to a mechanic....hope he is not taking my for a ride. He told me it will be around 1,000 I have that one on hold.

    No red light or waring message on display.

    The plugs are are very black when I checked them. I was wondering if some old gas might have fouled them.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    For the dead machine, the EMM can often be repaired.

    Send it to;
    DFI Technologies - Repair service for Polaris Ficht EMM modules
    www.dfitechnologies.com
    Email: [email protected]
    DFI Technologies
    22638 Canal Rd, Unit B
    Orange Beach, AL
    USA 36561
    +1 (251) 974-5210 Voice
    +1 (251) 974-5226 FAX


    Call first, and confirm the pricing and turn around time. Put a sticker right on the EMM with your name, address and phone number. Also list what year and model the EMM is for, and what the symptoms are.

    I would send them both EMM. If there is nothing wrong with an EMM, the charge should be minimal.

    Be sure to write down the HIN number on the EMM stickers, so you can be sure which EMM goes back into which machine. These EMM can NOT be swapped between engines, other than for short tests.

    In terms of further testing, have a look at this thread for some more tests you can do;
    polaris virage txi 1200 idles and dies

  5. #5

    Join Date
    Jun 2010
    Location
    Hilton Head
    Posts
    10
    Thanks for the EMM Info.

    What do you think is making the plugs black?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by kendo2u View Post
    ...What do you think is making the plugs black?
    Work through the diagnostics I have pointed you towards.

    How old is the fuel in the tank?

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I'd also like to WELCOME you to the Green Hulk Forums!!

    I like to start with the very basics, what's your fuel pressure?
    If it's going unregulated maybe it's too rich at idle (fouling plugs) and too lean at top (no power or power loss).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage TXi Problems - Need Advice
    By way2much2do in forum Polaris Open Discussion
    Replies: 24
    Last Post: 07-17-2009, 04:37 PM
  2. 2001 virage txi 1200 lean running injector
    By sposara in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-09-2008, 10:47 AM
  3. 2001 Virage TXI Fuel Problem, I THINK???
    By axman19 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-05-2008, 08:57 PM
  4. 2001 virage txi in limp mode
    By andrewplease in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-12-2007, 07:00 PM
  5. 2001 VIRAGE TXI- running lean
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-05-2007, 08:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •