Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592

    why would this coolent line be blocked off?

    hey guys,
    i have an 04 rxp and i have a 05 engine. i am finishing up the coolant system and realized that a port is capped off. my 2004 has a barb here that goes to the coolant tank.



  2. #2

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Prolly cause they used it with open loop is my guess. Which doesnt use a coolant tank.

  3. #3
    Banned User
    Join Date
    Sep 2009
    Posts
    441
    even with openloop you would want a line there, its a high point in the cooling system, you dont want air getting trapped there.

  4. #4

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    ok, ill take the one off my other engine, thanks

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by henn View Post
    even with openloop you would want a line there, its a high point in the cooling system, you dont want air getting trapped there.
    +1......

  6. #6

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    yea i ran it for the 1st time for about 30 seconds then posted this. i took it out and it hissed like a cat. anyway, back tot stock it goes. thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this the hose to block off when towing a PX 13 ?
    By dpracing in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-03-2013, 05:03 PM
  2. would this oil line work
    By crashjib in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-06-2011, 01:13 PM
  3. would this be too lean???
    By bow tie klr in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 06-10-2009, 12:04 PM
  4. Would this be under warrenty??
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-24-2006, 07:43 AM
  5. Would this be an ok mod setup for a budget????
    By kenshin89 in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-25-2005, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •