Results 1 to 9 of 9
  1. #1
    07'RXP
    Join Date
    Aug 2009
    Location
    Babylon NY
    Posts
    28

    RXP's first time out/Holy Crap :)

    Well I took the RXP out today for my first time and all I can say is holy crap. This thing pulls hrd and is very fast (GPS=72.4). Man this thing is loud, but sounds so mean and aggressive. Compared to my GSX this thing is huge, very comfortable and controlled ride. My wife took out the GSX and then jumped over to RXP and she didn't want to give it back. I am very happy with this ski. I almost want to sell the GSX and get my wife a RXP/RXT.
    I have a question, which I am not sure is normal but here it is. I was running the ski on the hose and when I went to spray lube into the TB hose, when I took off the cap, fluid (bombs lube) started spraying out. Also when on the hose (5 min) I noticed the ride plate was hot and smoking. Is this normal? Other than that everything went well.

    Thanks,
    Chris


  2. #2
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    should not be "smoking" for sure.
    I would NEVER run on the hose that long. I myself, never more than a minute.
    Probably burned up your carbon seal on the drive shaft.

  3. #3
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    The ride plate is a heat exchanger for the motor. was it just steam or did it smell like something was burning.

  4. #4
    07'RXP
    Join Date
    Aug 2009
    Location
    Babylon NY
    Posts
    28
    It was only steam, I definately didn't smell anything burning. I leaked some salt terminator on the top of the ride plate so it could have been that burning off. I never run the ski on the hose more than 5 min as recommended by Seadoo.
    Thanks,
    Chris

  5. #5
    StretchTTU's Avatar
    Join Date
    May 2010
    Location
    Humble, TX
    Posts
    55
    Quote Originally Posted by 97GSX View Post
    I never run the ski on the hose more than 5 min as recommended by Seadoo.
    Thanks,
    Chris
    I thought the manual says 2 mins max?

  6. #6
    I pew pew lazors
    Join Date
    Mar 2010
    Posts
    167
    Quote Originally Posted by StretchTTU View Post
    I thought the manual says 2 mins max?
    I've always heard 5 and I believe my manual ('05 RXP) says 5. Given that, I never run more than 3 just for the simple fact that I want my carbon seal to love me.

  7. #7
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,567
    +1
    4,784
    Quote Originally Posted by 97GSX View Post
    My wife took out the GSX and then jumped over to RXP and she didn't want to give it back. I am very happy with this ski. I almost want to sell the GSX and get my wife a RXP/RXT.
    LOL, trust me - two Doos are much better than one!

  8. #8
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    on the hose WAY too long!

  9. #9
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    maybe he thought the 4tecs were open looped.

    the water only cools off the exhaust not the engine.

    the rideplate is like a radiator so to speak

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First time out with my Modded RXP
    By jasonstang88 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 02-23-2009, 10:37 AM
  2. New mods first time out (Riva RXP)
    By turbojamie in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-30-2008, 02:39 PM
  3. RXP locked up first time out
    By XSV in forum Sea Doo Open Discussion
    Replies: 36
    Last Post: 05-17-2008, 02:23 PM
  4. First time out w/ my 06 rxp-results!!!
    By NoMo-xp4me in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-23-2007, 02:37 PM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •