Results 1 to 9 of 9
  1. #1
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123

    clueless as to what happened

    So me and my buddy were riding today and we both went for a pass. As i passed him and i look back i didn't see him so i stop. When i get to where he was his gp12r would not turn on, all you would hear is the spark when the start button was pressed. I towed him back to where we were and looked at it, tried hooked up a battery charger to it and cranking it and the same would happen. So we just decide to hang out for a while then head back to the marina.

    Soooo, 35 minutes later and i notice that his jet ski is sinking slowly. He freaks out and jumps off and takes the seat off and i look and the water was coming in, i have no idea how but it was sinking the whole rear end was under water. So i tow him back to the marina, took around 35 minutes, idk how my gp13r survived that horror story, but ok.

    My buddy gets home and he tries to check out what happened and we noticed the airbox cover was loose in the haul. Water had to have gotten in the carbs, i mean the rear end was under water. As he put it to drain, the pissers did not throw out water, instead, the haul would flood ? When i saw this i was confused.. so its all apart in his garage and we have no idea what happened. Hopefully tomorrow or as the week comes we can find out. Any help would be appreciated guys.


  2. #2

    Join Date
    Apr 2006
    Location
    South MS
    Posts
    1,095
    Check all the hoses in the rear, and the exhaust hoses. It could also have cracked the pump tunnel. Get underneath and look in front of the prop on the hull for a crack.

  3. #3
    Check for rubb marks on your inlet hose to make sure that vibrations didnt rub a hole in it.

    ( anyone know why my ski wont do a 360,l just replaced impeller and wear ring )

    97' GP760

  4. #4
    dont forget to check the hose in the rear that the drive shaft goes through

  5. #5
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123
    I will check the hoses, pump tunnel i checked and its perfect. The problem is that it doesnt even make an effort to turn over and crank, all you hear is one spark when ignition is pressed, maybe the starter ?

    What if the carbs sucked in water? Wouldnt it atleast make an effort to turn on?

  6. #6
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123
    I did check exhaust hoses and it seems to be all good back there.

  7. #7
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    do you have the plugs out when you tryed to crank it?

    if you have water inthe motor you need to get it out asap. and fog the crap out of it..

    i dont know much about the gprs but check every single hose and check for cracks or holes in the hull

  8. #8
    Banned User
    Join Date
    May 2010
    Location
    305
    Posts
    123
    Well we pulled it apart and the crank seized and the front cylinder in the back wall broke to pieces, piston is all messed up so is the dome. How the hell did this happen? His cyliders are ported btw, i dont see how this sank the boat though?

  9. #9
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    prob because it didnt sink it, you need to look for cracked hoses... i bet there is a pin hole..some where. on my ski i had asmall pin hole.. and withabout 10 mins of riding i saw my bilge pup kick on so i brought it home.. looked in side and water was half up the battery.. i drained it out and looked for cracks and cold not see anything till i put it on the hoist and lowerd it in the water and ran it to see water spraying in..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. any idea as to what this is?
    By Hagarules in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-02-2015, 09:33 PM
  2. Replies: 4
    Last Post: 11-16-2012, 09:23 PM
  3. GP1200R 66V broken piston pictures. Ideas to what happened?
    By cougar in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 10-06-2010, 05:45 PM
  4. What happened to the quotes?
    By 11 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 01-09-2006, 10:33 AM
  5. what happened to the cool 4-Tec title?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-06-2005, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •