Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    do i have the corect prop ?????

    my mods 2009 Fzs ,R2,C3 ,riva pipe, filter ,rive power color 13/24 ,R&D intake Grate,R&D ride Plate.
    my speed was 72Mph with full tank , RPM 7450.


    i was thinking to change the prop to 13/23 will i get more speed .

    my brother fx cruiser same mods but with stock ride plate and the new double prop << his speed was 71MPH ,Rpm 8100

    what do you think guys

    Thanks


  2. #2
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Right now you might as well not even have the R2 because you aren't taking advantage of the added RPM. 7400 is lower than stock. You need to get them up to around 8400.

    I'm running 77 with the stock boost wheel. With you running the C3 and R2 you should be over 80.

  3. #3
    Quote Originally Posted by hitman View Post
    Right now you might as well not even have the R2 because you aren't taking advantage of the added RPM. 7400 is lower than stock. You need to get them up to around 8400.

    I'm running 77 with the stock boost wheel. With you running the C3 and R2 you should be over 80.

    so you think i should change the prop to 13/23 or 13/22

    my boost was at 10 psi

  4. #4
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    Quote Originally Posted by silvertaws6 View Post
    so you think i should change the prop to 13/23 or 13/22

    my boost was at 10 psi
    are you using a powershot with the r2?
    i had the r2/c3 with a 13/23 skat.
    more rpms where 8200 to 8540 depending on what nozzle ring i was using. and my speeds where79/80+
    have you checked your afr?
    there are several things going on with your setup, for your rpms to be that low. you should be at least getting 8100 rpms. and you still have the oem pump and liner too?

  5. #5
    Quote Originally Posted by gordon lasiter #328 View Post
    are you using a powershot with the r2?
    i had the r2/c3 with a 13/23 skat.
    more rpms where 8200 to 8540 depending on what nozzle ring i was using. and my speeds where79/80+
    have you checked your afr?
    there are several things going on with your setup, for your rpms to be that low. you should be at least getting 8100 rpms. and you still have the oem pump and liner too?
    no i dont have powershot ,( do i need it will it gave more speed and RPM) i was thinking the proplem was the prop .
    i'll check my AFR this weekend

    pump,nozle all stock..

  6. #6
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by silvertaws6 View Post
    so you think i should change the prop to 13/23 or 13/22

    my boost was at 10 psi
    Hmmm? Something isn't right. Those RPM's are way too low for that set-up and I don't think it is all because of the prop. Switching the prop one degree on the trailing edge will not recover 700 - 900 RPM's.
    Boost is low, as well, for that set-up. The problem is I don't know where to tell you to start looking. There are other guys here who have much more wrenching experience than myself. I can only tell you from my experience riding and monitoring my ski. Sorry I can't be more help.
    FYI...
    I have my set-up close to yours and I see 8250 - 8550 rpms with 13lbs boost.

    Unless you somehow got a prop that was supposed to be 13/24 but is actually closer to a x/26, but I still don't think you would be that low on rpm's and boost.

    my .02 cents.

  7. #7

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528

    Talking

    get a prop that has a tru 22 pitch on the trailing edge!!!!!!!!!!!!!!!

  8. #8
    Quote Originally Posted by gmoeller View Post
    Hmmm? Something isn't right. Those RPM's are way too low for that set-up and I don't think it is all because of the prop. Switching the prop one degree on the trailing edge will not recover 700 - 900 RPM's.
    Boost is low, as well, for that set-up. The problem is I don't know where to tell you to start looking. There are other guys here who have much more wrenching experience than myself. I can only tell you from my experience riding and monitoring my ski. Sorry I can't be more help.
    FYI...
    I have my set-up close to yours and I see 8250 - 8550 rpms with 13lbs boost.

    Unless you somehow got a prop that was supposed to be 13/24 but is actually closer to a x/26, but I still don't think you would be that low on rpm's and boost.

    my .02 cents.
    thanks guys ,
    a frined got the solas 22 will get it from him and try it out .
    today i checked all the pipe houses if i have boost leak and NO .

    Also could it be the heat
    in my place its to HOT the temp reaches 95-100

  9. #9
    just did another test after oil change and sparks plugs

    same speed . it was so hot the temp was 50+ C

  10. #10
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by silvertaws6 View Post
    just did another test after oil change and sparks plugs

    same speed . it was so hot the temp was 50+ C
    122 degrees?! HOLY SCHIT.

    Well,.....weather does dramatically affect these skis.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do I have the Normal or Learner key?
    By wilddoktor in forum 2-Stroke Performance
    Replies: 10
    Last Post: 07-14-2015, 09:02 PM
  2. Jerry do you have the 2013 seadoo info? Its out!
    By Water4fire in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-01-2012, 08:08 AM
  3. do i have to register in the yamaha forum also???????
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-04-2006, 10:14 AM
  4. Instaling my BOV do I have to use the middle notch????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-22-2005, 07:32 PM
  5. Sponsons Anyone have the R&D? How do they compare?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-03-2005, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •