Results 1 to 5 of 5
  1. #1

    1996 gtx 787 stator?

    I believe the stators bad but i dont know if theres a voltage regulator that could be bad? my ski is not charging at all voltage is the same when the ski is off and running doesnt go up like it should for charging. so is it the stator or is there a regulator?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    there is a rectifier in the in the gray box...I believe that is what your looking for

  3. #3
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    X2^^

  4. #4
    right i figured the rectifier was the regulator. what im looking for is. is it that or the stator causing it not to charge?

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    it depends on what the stator looks like. have you pulled the front cover and inspected it for metal shavings and things of the like? it sounds like its the rectifier to me. replace that and if you have the problem still id start looking at the pick up on the stator and then the stator itself

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Leak - 1996 GTX 787
    By CZSteve in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-08-2014, 05:34 PM
  2. FS - Parts Seadoo 1996 gtx 787\800 mpem only brand new in box p/n 278 000 897
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-07-2014, 04:32 PM
  3. Idle speed on 1996 GTX 787?
    By CZSteve in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-01-2013, 12:14 PM
  4. GTX 751 and GTX 787 Stators
    By maczilla23 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-27-2011, 05:31 PM
  5. 1996 GTX (787) Limited RPMs... HELP!!!
    By krp713 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-29-2010, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •