Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790

    Riva ride plate from Jims plate & lost speed. Advise!

    Guys I took off my Jims closed loop plate and installed my Riva open loop plate. Well I went from 80.8 with full tank and 81.8 with 4 bars and now I am o nly hitting 77full and 78.5's with low fuel.
    The handleing is great IMO, but I want the speed back.

    I first had the wedge, but removed it. Seamed like to much.

    Well any advise and help would be great as to get my speed back.


    .


  2. #2

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    763
    +1
    26
    I changed mine out also (Jims skeg mod plat) - I'm at the same speed maybe + .5 (82+)

    Maybe you picked up a boost leak

  3. #3

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    did the weather change what was rpms before and after did u shim your plate

  4. #4
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    That is wierd. I know a lot of people that have gained 1-2mph by using the Riva plate instead. Maybe the angle of the plate needs to be work on a little more....

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Unmodded Riva plate? I thought you had to tweak them some

  6. #6
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    I use to use Jims RP and my speed was 83.5, changed to Riva Plate and gain 1.5 mile


    about loosing speed make sure from the silicon between the hull and the plate

  7. #7
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Well guys I believe weather was close, but ofcoarse not sure. The boat always ran 81+ never a hecup until the riva plate.

    I siliconed everything alot. I have changed a bunch of plates.

    I did my first runs with the riva wedge. I then pulled it off to no wedge.

    It is not shimed at all, but is rock solid and takes waves better imo.

    Any help would be great. Would pictures help of install.

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Water4fire View Post
    Well guys I believe weather was close, but ofcoarse not sure. The boat always ran 81+ never a hecup until the riva plate.

    I siliconed everything alot. I have changed a bunch of plates.

    I did my first runs with the riva wedge. I then pulled it off to no wedge.

    It is not shimed at all, but is rock solid and takes waves better imo.

    Any help would be great. Would pictures help of install.
    I think they made some changes to the riva plates so they are not all the same but I still would not expect that kinda speed loss. I assume the pump shoe is intact?

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    What year plate, and what year shoe is it on?

    Also I run the wedge, and if u haven't already done so u will have to adjust your holeshot rod to get full up after install. Mine had a similar issue where It turned on a dime, but couldn't get the nose up much for speed, till I adjusted the VTS rod.

  10. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Quote Originally Posted by speedskixp View Post
    I think they made some changes to the riva plates so they are not all the same but I still would not expect that kinda speed loss. I assume the pump shoe is intact?
    Yep, Pump shoe is perfect and I run a r&d girdle.

    Quote Originally Posted by psycho rxp View Post
    What year plate, and what year shoe is it on?

    Also I run the wedge, and if u haven't already done so u will have to adjust your holeshot rod to get full up after install. Mine had a similar issue where It turned on a dime, but couldn't get the nose up much for speed, till I adjusted the VTS rod.
    I believe the rod is as far as it can go back.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHO Riva Ride Plate vs Standard Ride Plate which to send to Jim
    By wakeboardmuppet in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-20-2010, 11:25 PM
  2. FS jim's ff riva ride plate for gpr
    By jayohentran in forum Yamaha Classifieds
    Replies: 6
    Last Post: 06-04-2010, 07:28 AM
  3. FS...XL1200/XLT1200/XL800/XLT800 Riva Ride Plate w/Jims FF MOD
    By need4pwr in forum Yamaha Classifieds
    Replies: 7
    Last Post: 08-23-2008, 08:51 AM
  4. Jims modified Riva Ride Plate
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 06-05-2008, 06:03 PM
  5. Riva ride plate VS Jim's cut plate?
    By Beagleman62 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 12-10-2007, 12:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •