Results 1 to 4 of 4
  1. #1

    93 sl 650 some ??'s

    Well back to getting this thing running/ back together and have a few question's. It does not have a water sepperator on it so I bought one question is where does it mount, or does it just hang on line? I replaced fuel pump with a new triple out. Question is do I still need to run the primer bulb? Hood prop rod does not hold hood up has anyone put a newer style holder on one of these older ski's? Or is there a way to Fix it.does anyone know of a supplier for decals Just looking for the polaris at the water line and the sl650 ones.Don't care for rest. If the thing run's when I get her back together I'll be respraying it. Thanks, Nate

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Doesn't look like it had one.

    They do install between the petcock and the fuel pump. Mine was mounted to the rear grab bar bolt with a bracket.

    I'd still run the primer.

    Not sure what hood prop you have. Is there a spring attached at the bottom of the rod?

    Deacls are discontinued. There are a few on Ebay right now, that's about it. Unless you go with custom graphics.

  3. #3
    Thanks, no spring is not hooked up was wondering what that was for.... I'll mount seperator like yours just have to fab a mount. Already did this for fuel pump as I'm going with a 780 style air box. Guess I'll leave primer in line will not hurt anything. I read that fuel line biz type lines are collasp'in on some members.Was going to redo hole ski in there line. The line has been changed over to black rubber already what do you think? thanks, Nate

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Hook the spring up to the hood rod and that'll be fixed.

    I personally like the reinforced fuel liunes myself, but to each his own.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sl 650 no spark
    By scottr2200 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-13-2007, 11:22 PM
  2. shot the 650
    By LANCE in forum Polaris Projects
    Replies: 4
    Last Post: 06-20-2007, 10:06 PM
  3. 95 650 no fuel
    By loveboxer in forum Polaris PWC Performance
    Replies: 12
    Last Post: 06-20-2007, 03:58 PM
  4. Need some help with a 650 LX
    By utahnewbie in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-04-2007, 11:59 PM
  5. 94 sl 650 syphon
    By punchtech in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 05-01-2007, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts