Results 1 to 5 of 5
  1. #1
    dreww's Avatar
    Join Date
    May 2007
    Location
    G.P.
    Posts
    182

    put on air intake, but lose power and rpms?

    ok, put a custom intake on my 15f, runs great. little more zip. so figured i'd do the same to my 12f.

    but results were different, i max at 6k rpms and takeoff is slower. doesnt sputter at low rpms like foul plugs do though. i replaced all plugs after getting home, but havent tried it on lake yet.

    any ideas? could that mod have triggered plug fouling? plugs had 117hrs on them but rode strong the week before intake.


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    We need a lil more info, and pics would be even better, did you use the same set up as you did on the 15f.........?

  3. #3
    dreww's Avatar
    Join Date
    May 2007
    Location
    G.P.
    Posts
    182
    thanks for replying.

    it is the same exact setup on both skis, air intake wise. just a plastic flex tubing and a cone filter.
    sorry, not at home to take pic, but very simple setup.

    maybe i should be looking for an exhaust leak like in the 15f post here with similar symptoms.

  4. #4
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    http://greenhulk.net/forums/showthread.php?t=128886

    this is what i did along with removing one of the water box's, revs 3 small bars passed 7 now, def feel better. not sure what your is like. could be the hose....

  5. #5
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    the only time i had something like that happen was when i swapped manifolds and it ran really lean, I had 2 bars past 7k when i did just the intake so something isnt right


    Sean

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Issues on air intake and turbo help
    By hondarepoman in forum Honda Performance
    Replies: 6
    Last Post: 07-10-2009, 08:18 PM
  2. prefilter over air intake causing lose of rpms
    By mxl16 in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-14-2007, 10:26 AM
  3. PPG L 1 Air Intake VS. Riva Power Filter
    By Ultra/RXP in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-07-2005, 01:24 PM
  4. PPG Level 1 Air Intake vs. Riva Power Filter
    By Ultra/RXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-07-2005, 05:03 PM
  5. Rear air intake for more power
    By Kinchyle in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-02-2005, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •