Results 1 to 5 of 5

Thread: Help no power.

  1. #1

    Angry Help no power.

    I have 2 GP1200 R I just bought with 60 hrs on them. I have replaced the top end on one, cleaned the carbs on both and added D plates on both. but neither ski will rev higher than 5500 RPM top speed 40 mph. Mechanic is stumped. Any Ideas. It must be the same problem for both ski's to act the same. Help!


  2. #2
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,156
    +1
    44
    What have you ruled out after you used the search button and done your own investigation based on that information?

  3. #3
    Quote Originally Posted by fullboogie View Post
    What have you ruled out after you used the search button and done your own investigation based on that information?
    Well we cleaned the carbs the ski's have sat the last 3 years, changed gas both catalytic converters were trashed so I took them off added D plates. they run great on the trailer but when i put them in the water no power at all slow to plane no top end speed and only 5500 rpm. I'm being told that only 2 of 3 cylinders are heating up would that be caused by carbs?

  4. #4
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,363
    +1
    55
    check each spark plug wire and make sure all got spark, you could be running on 2 cylinders

  5. #5
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,156
    +1
    44
    Check the PV's too. They may not be opening. And you may want to rebuild the carbs as opposed to cleaning them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help, no power to fuel pump 2005 12f
    By keanu in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 12-15-2010, 11:41 PM
  2. Please help no power!
    By IBADTON in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-06-2009, 03:47 PM
  3. Need help, no power!
    By billywilly in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-02-2007, 04:21 AM
  4. HELP- no power internal damage
    By tryintolearn in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-03-2007, 11:54 PM
  5. 02 GTX 4-Tec na Help No Power
    By ccgtxna in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-07-2006, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •