Results 1 to 3 of 3
  1. #1
    rxp12's Avatar
    Join Date
    Jan 2008

    Why wont my shock absorber stay on!!!

    hey guys, i didnt have any problems with my front shock until 60 hrs. i followed the seadoo service bulletin and moved the bottom bracket over 10 mm to the left. yea it didnt last 5 hrs. ive put it back on a hundred times and no luck. anyone have a way to keep it on?? im getting pretty tired of filling up with gas and holding the hood with my head lol

  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Nederland, Texas
    I had to tighten up all the bracketry on my RXTX. Once I did that everthing has been fine.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Central Florida
    LOL see my comments on this here:

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. in need of gas shock for front hood
    By txdj0709 in forum Polaris Classifieds
    Replies: 22
    Last Post: 12-11-2013, 02:30 PM
  2. 2002 Virage TXI wont stay running DI
    By ncdoo in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-23-2012, 09:43 PM
  3. Hood Shock
    By rxpblast in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-12-2008, 05:17 PM
  4. Front hatch Shock RXT
    By wavehummer in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-17-2007, 04:02 PM
  5. Shock Absorbers!
    By Mr Bill in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 03-04-2006, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts